summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <[email protected]>2024-12-24 01:13:35 +0800
committerZheng Junjie <[email protected]>2025-01-25 01:05:27 +0800
commite9cccd824e436d87c3daa42479b99e093254603b (patch)
tree5c75f4f4dea6d34b68b0da00a388a9862992ccb6
parent0d133fdd7342020f4aa78441698f34d877c678d8 (diff)
gnu: sed: Fix build to loongarch64.
* gnu/packages/base.scm (sed)[native-inputs]: When target is loongarch64, add config. [arguments]: When target is loongarch64, Add update-config-scripts phase. Change-Id: I056d5004ec326f8c5b30853d5ea401ea12a949b7
-rw-r--r--gnu/packages/base.scm18
1 files changed, 17 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 4639050623..4c96ffa1a4 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -217,7 +217,23 @@ including, for example, recursive directory searching.")
(modules '((guix build utils)))))
(build-system gnu-build-system)
(synopsis "Stream editor")
- (native-inputs (list perl)) ;for tests
+ (native-inputs (append (if (target-loongarch64?)
+ (list config)
+ '())
+ (list perl))) ;for tests
+ (arguments (if (target-loongarch64?)
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'update-config-scripts
+ (lambda* (#:key inputs native-inputs #:allow-other-keys)
+ ;; Replace outdated config.guess and config.sub.
+ (for-each (lambda (file)
+ (install-file
+ (search-input-file
+ (or native-inputs inputs)
+ (string-append "/bin/" file)) "./build-aux"))
+ '("config.guess" "config.sub"))))))
+ '()))
(description
"Sed is a non-interactive, text stream editor. It receives a text
input from a file or from standard input and it then applies a series of text