summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-01 19:56:09 +0100
committerRicardo Wurmus <[email protected]>2025-01-20 21:37:29 +0100
commite0f6eeebe868fdb7a1b86f26b28cbdbdecd0ec01 (patch)
tree55bf6c7fe0110d440c459b62a27ec156dacb9e1a
parent38065d81045ad4c6c7b2a4f923db17e4a8b06462 (diff)
gnu: python-matrix-nio: Use test-flags.
* gnu/packages/matrix.scm (python-matrix-nio)[arguments]: Remove custom 'check phase; disable some tests using #:test-flags. Change-Id: Ib7c826b1746c418f8c917581695a63a486c4acd7
-rw-r--r--gnu/packages/matrix.scm23
1 files changed, 10 insertions, 13 deletions
diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index 32ae62fcb4..f2319004d3 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2020 Giacomo Leidi <[email protected]>
;;; Copyright © 2022 Aleksandr Vityazev <[email protected]>
;;; Copyright © 2022 Morgan Smith <[email protected]>
+;;; Copyright © 2025 Ricardo Wurmus <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -169,8 +170,14 @@ homeserver and generally help bootstrap the ecosystem.")
(base32 "110wg1grhqqgwvlgr98r2k8wxcggpj7lbdwmgkgmi2l7qj1vw3dm"))))
(build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
+ (list
+ #:test-flags
+ '(list "tests" "-k"
+ (string-append
+ "not test_upload_binary_file_object "
+ "and not test_connect_wrapper"))
+ #:phases
+ '(modify-phases %standard-phases
(add-after 'unpack 'relax-requirements
(lambda _
(substitute* "pyproject.toml"
@@ -182,17 +189,7 @@ homeserver and generally help bootstrap the ecosystem.")
(lambda* (#:key inputs outputs #:allow-other-keys)
(copy-recursively (string-append
(assoc-ref inputs "tests") "/tests")
- "tests")
- #t))
- (replace 'check
- (lambda* (#:key tests? inputs outputs #:allow-other-keys)
- (when tests?
- (add-installed-pythonpath inputs outputs)
- ;; FIXME: two tests fail, for unknown reasons
- (invoke "python" "-m" "pytest" "-vv" "tests" "-k"
- (string-append
- "not test_upload_binary_file_object "
- "and not test_connect_wrapper"))))))))
+ "tests"))))))
(native-inputs
`(("python-pytest" ,python-pytest)
("python-poetry-core" ,python-poetry-core)