summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-10 19:46:11 +0000
committerSharlatan Hellseher <[email protected]>2024-12-30 15:07:39 +0000
commitd336816faf85310bff211ca78275b990a24d3673 (patch)
tree391941f792ee17edea53ad70e2fe4eb0e92f4d0d
parent1d4aed833cf3bd1d528015056546238b520a0186 (diff)
gnu: python-cmyt: Update to 2.0.1.
* gnu/packages/astronomy.scm (python-cmyt): Update to 2.0.1. [source]: Swap to git checkout containing tests. [arguments]<phases>: Add 'relax-requirements. [native-inputs]: Remove python-setuptools and python-wheel; add python-hatchling. [description]: Adjust fill column. Change-Id: I5eb5cf848c26e3fb9f16f7d611d06047387981e7
-rw-r--r--gnu/packages/astronomy.scm27
1 files changed, 19 insertions, 8 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 9bf7b1d74f..cbc7d36316 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3734,28 +3734,39 @@ attempting to maintain ISTP compliance
(define-public python-cmyt
(package
(name "python-cmyt")
- (version "2.0.0")
+ (version "2.0.1")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "cmyt" version))
+ (method git-fetch) ; no tests in the PyPI tarball
+ (uri (git-reference
+ (url "https://github.com/yt-project/cmyt")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1zabmckr1z637pfqqvlkj0asfqqvx2x92163dby8x0c8yiqgdvjb"))))
+ (base32 "0d1szsgjd09ya53vx7g5ryz2jdxl19p9rvrm4xz8v53vbqrp18cv"))))
(build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "pyproject.toml"
+ ;; numpy>=1.26
+ ((">=1.26") ">=1.23")))))))
(native-inputs
(list python-colorspacious
python-pytest
python-pytest-mpl
- python-setuptools
- python-wheel))
+ python-hatchling))
(propagated-inputs
(list python-matplotlib
python-numpy))
(home-page "https://yt-project.org/")
(synopsis "Matplotlib colormaps from the yt project")
(description
- "This package provides a range of colormaps designed for scientific
-use with Matplotlib. It includes perceptually uniform sequential colormaps such
+ "This package provides a range of colormaps designed for scientific use
+with Matplotlib. It includes perceptually uniform sequential colormaps such
as @code{abre}, @code{dusk}, @code{kepl}, and @code{octarine}, as well as
monochromatic sequential colormaps like @code{blue}, @code{green}, and
@code{red}, and others (@code{algae}, @code{pastel}, and @code{xray}).")