summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2018-06-29 22:09:36 +0200
committerRicardo Wurmus <[email protected]>2018-06-29 22:09:36 +0200
commitcda7f4bc8ecf331d623c7d37b01931a46830c648 (patch)
treeff2cf5a7d87f58660887423b585723e987c95382
parent9ca381f0f1f5fe34f34bb8dc87f7d1739880bca1 (diff)
gnu: inkscape: Fix build with poppler.
* gnu/packages/inkscape.scm (inkscape)[source]: Add upstream patch to fix incompatibility with latest version of poppler.
-rw-r--r--gnu/packages/inkscape.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index de9940df1c..8471cf2392 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 John Darrington <[email protected]>
;;; Copyright © 2014, 2016 Mark H Weaver <[email protected]>
-;;; Copyright © 2016 Ricardo Wurmus <[email protected]>
+;;; Copyright © 2016, 2018 Ricardo Wurmus <[email protected]>
;;; Copyright © 2017 Marius Bakke <[email protected]>
;;; Copyright © 2018 Tobias Geerinckx-Rice <[email protected]>
;;;
@@ -54,7 +54,16 @@
"inkscape-" version ".tar.bz2"))
(sha256
(base32
- "1chng2yw8dsjxc9gf92aqv7plj11cav8ax321wmakmv5bb09cch6"))))
+ "1chng2yw8dsjxc9gf92aqv7plj11cav8ax321wmakmv5bb09cch6"))
+ (patches
+ (list (origin
+ (method url-fetch)
+ (uri (string-append "https://gitlab.com/inkscape/inkscape/commit/"
+ "a600c6438fef2f4c06f9a4a7d933d99fb054a973.diff"))
+ (file-name "inkscape-poppler-compat.patch")
+ (sha256
+ (base32
+ "19dam5vsy571xszgjddl5g0958dmcsv0wvgxidp4bhj2lban222i")))))))
(build-system cmake-build-system)
(inputs
`(("aspell" ,aspell)