summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2024-12-31 20:46:58 +0200
committerEfraim Flashner <[email protected]>2025-01-06 12:22:33 +0200
commitc5c3a4ddd398e87010ad743908d1c699d8c128dd (patch)
tree025bb6f599dc89d1688628015ee5288382d6f905
parent5d9d470b8652b64afb6a48a253a3b30a629e6f2b (diff)
gnu: Add rust-xsalsa20poly1305-0.9.
* gnu/packages/crates-crypto.scm (rust-xsalsa20poly1305-0.9): New variable. Change-Id: Ic46b495f1b2cdb026b4bade836eb6d4851687a38
-rw-r--r--gnu/packages/crates-crypto.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 4ab8d77484..1cb1c59aa9 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -6430,6 +6430,30 @@ Diffie-Hellman key exchange, with curve operations provided by
rand_core.")
(license license:bsd-3)))
+(define-public rust-xsalsa20poly1305-0.9
+ (package
+ (name "rust-xsalsa20poly1305")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "xsalsa20poly1305" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1ixnzy6srqk9gkxyh2rrwhpvnc0v3z3gfxgfg36q2zsnaz9xm9h2"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-aead" ,rust-aead-0.5)
+ ("rust-poly1305" ,rust-poly1305-0.8)
+ ("rust-salsa20" ,rust-salsa20-0.10)
+ ("rust-subtle" ,rust-subtle-2)
+ ("rust-zeroize" ,rust-zeroize-1))))
+ (home-page "https://github.com/RustCrypto/AEADs")
+ (synopsis "DEPRECATED: please use the `crypto_secretbox` crate")
+ (description
+ "DEPRECATED: please use the `crypto_secretbox` crate.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-z85-3
(package
(name "rust-z85")