summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2024-12-25 16:31:50 +0200
committerEfraim Flashner <[email protected]>2025-01-06 12:19:11 +0200
commitc527af4ad9a1e681ad36c4024b90d35bee98ff79 (patch)
tree7dd29e14a7748fb8d5b4a6e0beaeec1a4f9392f4
parent9e7db7dceeb1f7477751bd320986235c3c9550cf (diff)
gnu: libchewing: Update to 0.9.1.
* gnu/packages/language.scm (libchewing): Update to 0.9.1. [arguments]: Remove a phase lowering the version requirement for rust-clap-mangen. Change-Id: Ica52cebe2a59f5a4a7b39df68723f613b9ac2158
-rw-r--r--gnu/packages/language.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/language.scm b/gnu/packages/language.scm
index e1df008d77..43c89a6ed9 100644
--- a/gnu/packages/language.scm
+++ b/gnu/packages/language.scm
@@ -272,7 +272,7 @@ Random Cage Fighting Birds, Cool Music etc.")
(define-public libchewing
(package
(name "libchewing")
- (version "0.9.0")
+ (version "0.9.1")
(source
(origin
(method git-fetch)
@@ -281,7 +281,7 @@ Random Cage Fighting Birds, Cool Music etc.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1n0w9niff46w7vncs699gj4y2xghn1sbl0f4mg5x33dcapqd14sg"))))
+ (base32 "0gh64wvrk5pn0fhmpvj1j99d5g7f7697rk96zbkc8l72yjr819z5"))))
(build-system cargo-build-system)
(arguments
`(#:modules ((guix build cargo-build-system)
@@ -305,10 +305,6 @@ Random Cage Fighting Birds, Cool Music etc.")
(("rust-tempfile" ,rust-tempfile-3))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'allow-older-version-of-clap-mangen
- (lambda _
- (substitute* "tools/Cargo.toml"
- (("0.2.12") "0.2.11"))))
(add-after 'configure 'cmake-configure
(lambda args
(apply (assoc-ref cmake:%standard-phases 'configure)