summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-06 20:32:57 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:39 +0000
commitc37f11f6287277bd72250e2a7fbbbb419345ec4e (patch)
tree62c060bd97d68e3de9d6805def004b87e12d452e
parentc007debac88c86fedacc91f3313ec32bb6c799dd (diff)
gnu: Add go-github-com-masterminds-squirrel.
* gnu/packages/golang-xyz.scm (go-github-com-masterminds-squirrel): New variable. Change-Id: I14dbeb77ccb8d1c2a7ff0e037bd0dc18e44d187a
-rw-r--r--gnu/packages/golang-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index e925ce1420..dfc482792a 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -8708,6 +8708,36 @@ semantic versions. Specifically it provides the ability to:
functions.")
(license license:expat)))
+(define-public go-github-com-masterminds-squirrel
+ (package
+ (name "go-github-com-masterminds-squirrel")
+ (version "1.5.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Masterminds/squirrel")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ws7p3gchw6n81sfdhpk1pbh7gsj1fm7fbjah702d7q1gbn00vja"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/Masterminds/squirrel"))
+ (native-inputs
+ (list go-github-com-go-sql-driver-mysql
+ go-github-com-lib-pq
+ go-github-com-mattn-go-sqlite3
+ go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-lann-builder))
+ (home-page "https://github.com/Masterminds/squirrel")
+ (synopsis "Fluent SQL generation for golang")
+ (description
+ "Package squirrel provides a fluent SQL generator.")
+ (license license:expat)))
+
(define-public go-github-com-matryer-try
(package
(name "go-github-com-matryer-try")