summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <[email protected]>2024-08-03 23:04:36 +0200
committerHilton Chain <[email protected]>2024-12-30 19:16:19 +0800
commitc26287d7966986a81ab3481e33ba7d20c62d09f7 (patch)
treeba7a680221798caf32f7e9f562a7e29506155d18
parent121e96dca273ab407df11725da0026ee34abdf79 (diff)
gnu: Add dlpack.
* gnu/packages/machine-learning.scm (dlpack): New variable. Change-Id: I9223e5c3b8f8317f88954cfdaccdfa11a51b7167 Signed-off-by: Hilton Chain <[email protected]> Modified-by: Hilton Chain <[email protected]>
-rw-r--r--gnu/packages/machine-learning.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index b05ea0c202..40727b55eb 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -134,6 +134,28 @@
#:use-module (gnu packages xorg)
#:use-module (ice-9 match))
+(define-public dlpack
+ (package
+ (name "dlpack")
+ (version "1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dmlc/dlpack")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "169slm88jin4ddhdwk1qhqzzkhkwk1jrz35i7abhcqkry9wjib4f"))))
+ (build-system cmake-build-system)
+ (arguments (list #:tests? #f)) ;No tests.
+ (home-page "https://github.com/dmlc/dlpack")
+ (synopsis "In memory tensor structure")
+ (description
+ "DLPack is an in-memory tensor structure for sharing tensors among
+frameworks.")
+ (license license:asl2.0)))
+
(define-public fasttext
(package
(name "fasttext")