summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVasilii Smirnov <[email protected]>2025-02-13 15:34:48 +0100
committerSharlatan Hellseher <[email protected]>2025-02-13 23:12:23 +0000
commitbcc776301cb54ea29950ec520f4ae286c83483ac (patch)
tree232d93f08a4123f8220708b40559faa8f4c562c1
parent87dd002575fb5090649e56a3a2d10b86b1773c74 (diff)
gnu: Add specification-ybsc.
* gnu/packages/specifications.scm (specification-ybsc): New variable. Change-Id: I5d7a40dfee10f19fae7a80dfd1fc13d8a15ef4f1 Co-authored-by: Sharlatan Hellseher <[email protected]> Signed-off-by: Sharlatan Hellseher <[email protected]>
-rw-r--r--gnu/packages/specifications.scm56
1 files changed, 55 insertions, 1 deletions
diff --git a/gnu/packages/specifications.scm b/gnu/packages/specifications.scm
index b4b59ea0f6..7c757c323b 100644
--- a/gnu/packages/specifications.scm
+++ b/gnu/packages/specifications.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2024 Artyom V. Poptsov <[email protected]>
-;;; Copyright © 2024 Sharlatan Hellseher <[email protected]>
+;;; Copyright © 2024-2025 Sharlatan Hellseher <[email protected]>
+;;; Copyright © 2025 Vasilii Smirnov <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -202,3 +203,56 @@ documentation, schemas and source of Golang module.")
spectroscopic data reduction (e.g. standard star spectra, atmospheric
extinction curves, line lists for calibration lamps).")
(license license:bsd-3))))
+
+(define-public specification-ybsc
+ (package
+ (name "specification-ybsc")
+ (version "5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://tdc-www.harvard.edu/catalogs/ybsc" version
+ ".gz"))
+ (sha256
+ (base32 "1vbvxhw1i3h2r61zgqy7hpwpa4pmc0jh6mknridvx3xyj0g4pi1x"))))
+ (build-system copy-build-system)
+ (arguments
+ (list
+ #:install-plan #~'(("ybsc5" "share/ybsc5"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'install-documentation
+ (lambda _
+ (let ((doc (string-append #$output "/share/doc")))
+ (mkdir-p doc)
+ (with-directory-excursion doc
+ (copy-file
+ #+(origin
+ (method url-fetch)
+ (uri (string-append
+ "http://tdc-www.harvard.edu/catalogs/ybsc"
+ (package-version this-package) ".readme"))
+ (sha256
+ (base32
+ "0vki8cjwgwdfck43sbmm5d8qlk7sag6s2vqq8gp5z29nrpa0j93d")))
+ "README")
+ (copy-file
+ #+(origin
+ (method url-fetch)
+ (uri (string-append
+ "http://tdc-www.harvard.edu/catalogs/ybsc5.notes.gz"
+ (package-version this-package) ".notes.gz"))
+ (sha256
+ (base32
+ "018lvy24pzf3ifq7dkryjnz2ny46311g4dnfifpv0rddmv7di2fl")))
+ "notes.gz")
+ (system* "gunzip" "notes.gz"))))))))
+ (home-page "http://tdc-www.harvard.edu/catalogs/bsc5.html")
+ (synopsis "Yale Bright Star Catalogue")
+ (description
+ "This package provides an ASCII version of @acronym{Yale Bright Star
+Catalogue, @url{https://en.wikipedia.org/wiki/Bright_Star_Catalogue, YBSC}}
+catalog which is a widely used source of basic astronomical and astrophysical
+data for stars brighter than magnitude 6.5. It provides 9110 stars including
+B1950 positions, proper motions, magnitudes, and, usually, spectral types.")
+ (license license:public-domain)))