summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-12-24 21:59:14 +0200
committerEfraim Flashner <efraim@flashner.co.il>2025-01-06 12:18:14 +0200
commitb7741fab9ec9a87226498338463d9a12eb4ed3fc (patch)
tree6ee31aba35be027aa4e210f703e29c5a04719bac
parent438762e5b0fb0966e2a3bd06e5e4bf9bca8549dc (diff)
gnu: rust-webbrowser-0.8: Update to 0.8.15.
* gnu/packages/crates-io.scm (rust-webbrowser-0.8): Update to 0.8.15. [source]: Remove patch. [arguments]: Don't skip the build. Add cargo-test-flags. [cargo-inputs]: Add rust-core-foundation-0.9, rust-home-0.5, rust-jni-0.21, rust-ndk-context-0.1, rust-objc-0.2, rust-raw-window-handle-0.5. [cargo-development-inputs]: Add rust-actix-files-0.6, rust-actix-web-4, rust-crossbeam-channel-0.5, rust-env-logger-0.9, rust-ndk-glue-0.5, rust-rand-0.8, rust-serial-test-0.10, rust-tokio-1, rust-urlencoding-2. [native-inputs]: Add pkg-config. [inputs]: Add zstd:lib. * gnu/packages/patches/rust-webbrowser-remove-unsupported-os.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it. Change-Id: Ib585361789c2615654ddeaab88aadcab702ac6c0
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/crates-io.scm37
-rw-r--r--gnu/packages/patches/rust-webbrowser-remove-unsupported-os.patch24
3 files changed, 28 insertions, 34 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 262c1362af..094bf8d690 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -2192,7 +2192,6 @@ dist_patch_DATA = \
%D%/packages/patches/rust-poem-1-fewer-deps.patch \
%D%/packages/patches/rust-rspec-1-remove-clippy.patch \
%D%/packages/patches/rust-trash-2-update-windows.patch \
- %D%/packages/patches/rust-webbrowser-remove-unsupported-os.patch \
%D%/packages/patches/rust-wl-clipboard-rs-newer-wl.patch \
%D%/packages/patches/rw-igraph-0.10.patch \
%D%/packages/patches/rxvt-unicode-fix-cursor-position.patch \
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a4bebeb44a..990000a974 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -97998,25 +97998,44 @@ for Wasm in browsers.")
(define-public rust-webbrowser-0.8
(package
(name "rust-webbrowser")
- (version "0.8.8")
+ (version "0.8.15")
(source
(origin
(method url-fetch)
(uri (crate-uri "webbrowser" version))
(file-name (string-append name "-" version ".tar.gz"))
- ;; Explicitely remove dependencies for unsupported operating systems,
- ;; to avoid pulling many dependencies and causing rust world rebuilds.
- (patches (search-patches "rust-webbrowser-remove-unsupported-os.patch"))
- (patch-flags '("-p0"))
(sha256
- (base32 "0zk1qidyksspa8pgvq8bh2lyqmmrs0fr5r1qsyhbzrawpn2w972p"))))
+ (base32 "12zw844al9kf32p5llv6dbqzaky9fa3ng497i3sk8mj0m5sswryv"))))
(build-system cargo-build-system)
(arguments
- `(#:skip-build? #t
- #:cargo-inputs (("rust-dirs" ,rust-dirs-4)
+ `(#:cargo-test-flags '("--"
+ "--skip=os::tests_xdg::test_xdg_open_local_file"
+ "--skip=tests::test_existence_default"
+ "--skip=tests::test_local_file_abs_path"
+ "--skip=tests::test_local_file_rel_path"
+ "--skip=tests::test_local_file_uri"
+ "--skip=tests::test_open_default")
+ #:cargo-inputs (("rust-core-foundation" ,rust-core-foundation-0.9)
+ ("rust-home" ,rust-home-0.5)
+ ("rust-jni" ,rust-jni-0.21)
("rust-log" ,rust-log-0.4)
+ ("rust-ndk-context" ,rust-ndk-context-0.1)
+ ("rust-objc" ,rust-objc-0.2)
+ ("rust-raw-window-handle" ,rust-raw-window-handle-0.5)
("rust-url" ,rust-url-2)
- ("rust-web-sys" ,rust-web-sys-0.3))))
+ ("rust-web-sys" ,rust-web-sys-0.3))
+ #:cargo-development-inputs
+ (("rust-actix-files" ,rust-actix-files-0.6)
+ ("rust-actix-web" ,rust-actix-web-4)
+ ("rust-crossbeam-channel" ,rust-crossbeam-channel-0.5)
+ ("rust-env-logger" ,rust-env-logger-0.9)
+ ("rust-ndk-glue" ,rust-ndk-glue-0.5)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-serial-test" ,rust-serial-test-0.10)
+ ("rust-tokio" ,rust-tokio-1)
+ ("rust-urlencoding" ,rust-urlencoding-2))))
+ (native-inputs (list pkg-config))
+ (inputs (list (list zstd "lib")))
(home-page "https://github.com/amodm/webbrowser-rs")
(synopsis "Open URLs in web browsers available on a platform")
(description
diff --git a/gnu/packages/patches/rust-webbrowser-remove-unsupported-os.patch b/gnu/packages/patches/rust-webbrowser-remove-unsupported-os.patch
deleted file mode 100644
index 9fea1e1665..0000000000
--- a/gnu/packages/patches/rust-webbrowser-remove-unsupported-os.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- Cargo.toml 2023-05-07 13:39:13.029066693 +0100
-+++ Cargo.toml 2023-05-07 13:39:22.545138206 +0100
-@@ -67,21 +67,3 @@
- [target."cfg(target_arch = \"wasm32\")".dependencies.web-sys]
- version = "0.3"
- features = ["Window"]
--
--[target."cfg(target_os = \"android\")".dependencies.jni]
--version = "0.21"
--
--[target."cfg(target_os = \"android\")".dependencies.ndk-context]
--version = "0.1"
--
--[target."cfg(target_os = \"android\")".dev-dependencies.ndk-glue]
--version = ">= 0.3, <= 0.7"
--
--[target."cfg(target_os = \"ios\")".dependencies.objc]
--version = "0.2.7"
--
--[target."cfg(target_os = \"ios\")".dependencies.raw-window-handle]
--version = "0.5.0"
--
--[target."cfg(target_os = \"macos\")".dependencies.core-foundation]
--version = "0.9"