summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-09 12:40:55 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:48 +0000
commitb102e120d57b1f790c4ee7bf9a71ffe06db2126b (patch)
treeae7145bd3be8ba8e127b7b59deaab4807a4a9fc3
parent027356f66c0a392861d3fa4bd15e26b09480f47c (diff)
gnu: go-github-com-twpayne-go-xdg-v3: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-twpayne-go-xdg-v3): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Icfea33020fcadb4b47cdced47df203886b3260b4
-rw-r--r--gnu/packages/golang-xyz.scm27
-rw-r--r--gnu/packages/golang.scm24
2 files changed, 27 insertions, 24 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index b73f19ca0b..8773c0fa03 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -13291,6 +13291,33 @@ supported by the time package
(list
#:import-path "github.com/twpayne/go-vfs")))))
+(define-public go-github-com-twpayne-go-xdg-v3
+ (package
+ (name "go-github-com-twpayne-go-xdg-v3")
+ (version "3.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/twpayne/go-xdg")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0j8q7yzixs6jlaad0lpa8hs6b240gm2cmy0yxgnprrbpa0y2r7ln"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/twpayne/go-xdg/v3"))
+ (native-inputs
+ (list go-github-com-stretchr-testify
+ go-github-com-twpayne-go-vfs-1.0.1))
+ (home-page "https://github.com/twpayne/go-xdg/")
+ (synopsis "Functions related to freedesktop.org")
+ (description
+ "Package @code{xdg} provides functions related to
+@uref{freedesktop.org}.")
+ (license license:expat)))
+
(define-public go-github-com-urfave-cli
(package
(name "go-github-com-urfave-cli")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f82d07edf1..462beb6282 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2905,30 +2905,6 @@ temporal directories.")
@code{go-github-com-twpayne-go-vfs} and @code{go-github-com-spf13-afero}.")
(license license:expat)))
-(define-public go-github-com-twpayne-go-xdg-v3
- (package
- (name "go-github-com-twpayne-go-xdg-v3")
- (version "3.1.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/twpayne/go-xdg")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0j8q7yzixs6jlaad0lpa8hs6b240gm2cmy0yxgnprrbpa0y2r7ln"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/twpayne/go-xdg/v3"))
- (native-inputs
- (list go-github-com-stretchr-testify go-github-com-twpayne-go-vfs-1.0.1))
- (home-page "https://github.com/twpayne/go-xdg/")
- (synopsis "Functions related to freedesktop.org")
- (description "Package @code{xdg} provides functions related to
-@uref{freedesktop.org}.")
- (license license:expat)))
-
(define-public go-github-com-delthas-go-libnp
(let ((commit "0e45ece1f878f202fee2c74801e287804668f677"))
(package