summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-02-07 09:47:20 +0000
committerSharlatan Hellseher <[email protected]>2025-02-07 09:49:56 +0000
commitb03db2877e127890d6358456c2c54eb4f1f16356 (patch)
treeb5614745c89543e6272f3afae04f4df87054894d
parentd743ff99069fc7c1bfdbc79c0d980fd178a361c9 (diff)
gnu: Add go-git-sr-ht-rjarry-go-opt-v2.
* gnu/packages/golang-xyz.scm (go-git-sr-ht-rjarry-go-opt-v2): New variable. Change-Id: Ia45805e944fc5fefbb750f801c4edae0aed4622d
-rw-r--r--gnu/packages/golang-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 2ff1093cb4..2af3339197 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -374,6 +374,24 @@ annotations on struct fields. It came as a spin-off from
commands.")
(license license:expat)))
+(define-public go-git-sr-ht-rjarry-go-opt-v2
+ (package
+ (inherit go-git-sr-ht-rjarry-go-opt)
+ (name "go-git-sr-ht-rjarry-go-opt-v2")
+ (version "2.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~rjarry/go-opt")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1092926vcgkhp2yjpvlx7g7q60j0bbkkq6n4v1nv2mapxvrs7xjf"))))
+ (arguments
+ (list
+ #:import-path "git.sr.ht/~rjarry/go-opt/v2"))))
+
(define-public go-git-sr-ht-rockorager-tcell-term
(package
(name "go-git-sr-ht-rockorager-tcell-term")