summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGNU Guix Live <[email protected]>2025-01-05 19:46:28 +0100
committer宋文武 <[email protected]>2025-01-07 18:40:04 +0800
commitabf5d2ac02706e2da3123d47d82546ab282f8537 (patch)
treedf5ede0934d7af6512c3b5c234284e3ca2470b47
parent44b233125b45c1505100883ff7aed1c9a65b96b3 (diff)
gnu: tinmop: Update to 0.9.9.1414213562373.
* gnu/packages/web-browsers.scm (tinmop): Update to 0.9.9.1414213562373. [native-inputs]: Add bash-completion, pkg-config and which. [inputs]: Remove sbcl-osicat. Add sdl2-ttf. [arguments]: Update 'fix-configure.ac phase. Remove 'fix-asdf phase. Change-Id: Ib8eca6b1b6f36ca7bfdb7209605715be7215be76 Signed-off-by: 宋文武 <[email protected]>
-rw-r--r--gnu/packages/web-browsers.scm28
1 files changed, 16 insertions, 12 deletions
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index d035e19476..d680761f74 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -864,7 +864,7 @@ http, and https via third-party applications.")
(define-public tinmop
(package
(name "tinmop")
- (version "0.9.9.14142135623")
+ (version "0.9.9.1414213562373")
(source
(origin
(method git-fetch)
@@ -873,20 +873,23 @@ http, and https via third-party applications.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "02kp527gyh60fm2ss92wy3k3m9fih82wvzndri98sj2zc0wgcnki"))))
+ (base32 "1grcngb6rnyzkdkf52m62m1kmd8nxm9m85bpg2py5mp3ghf5y5gp"))))
(build-system gnu-build-system)
(native-inputs
(list autoconf
automake
+ bash-completion
gnu-gettext
libjpeg-turbo
imagemagick
mandoc
nano
openssl
+ pkg-config
sbcl
tk
unzip
+ which
xdg-utils))
(inputs
(list ncurses
@@ -913,7 +916,6 @@ http, and https via third-party applications.")
sbcl-log4cl
sbcl-marshal
sbcl-nodgui
- sbcl-osicat
sbcl-parse-number
sbcl-percent-encoding
sbcl-purgatory
@@ -924,6 +926,7 @@ http, and https via third-party applications.")
sbcl-unix-opts
sbcl-usocket
sbcl-yason
+ sdl2-ttf
sqlite))
(arguments
`(#:tests? #f
@@ -943,15 +946,16 @@ http, and https via third-party applications.")
(("AC_PATH_PROGS.+GIT")
"dnl")
(("AC_PATH_PROG.+GPG")
- "dnl"))
- #t))
- (add-after 'configure 'fix-asdf
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "Makefile.in"
- (("LISP_COMPILER) ")
- (string-concatenate
- '("LISP_COMPILER) --eval \"(require 'asdf)\" "
- "--eval \"(push \\\"$$(pwd)/\\\" asdf:*central-registry*)\" "))))
+ "dnl")
+ (("AC_PATH_PROG.+SDL2")
+ "dnl ")
+ (("AC_CHECK_HEADER.+ttf")
+ "dnl "))
+ (substitute* "Makefile.am"
+ (("dist_completion_DATA")
+ "#")
+ (("completiondir")
+ "#"))
#t)))))
(synopsis
"Gemini, gopher, kami and mastodon/pleroma client with a terminal interface")