summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntero Mejr <[email protected]>2023-06-04 17:42:21 +0000
committerDanny Milosavljevic <[email protected]>2024-12-22 13:16:56 +0100
commitaab9393372db11f3f2f9e471ae1f4ba28dba8741 (patch)
tree482032dd24cb1c355abee485533e70b0df677f35
parenta8307663562d040fe3408040215f69f9912b9253 (diff)
gnu: Add perl-mail-rfc822-address.
* gnu/packages/perl.scm (perl-mail-rfc822-address): New variable. Signed-off-by: Danny Milosavljevic <[email protected]>
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 2afa9fd858..18b148c5dc 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -7092,6 +7092,27 @@ simple means to send email from a perl script. The module only
requires Perl5 and a network connection.")
(license license:perl-license)))
+(define-public perl-mail-rfc822-address
+ (package
+ (name "perl-mail-rfc822-address")
+ (version "0.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/P/PD/PDWARREN/Mail-RFC822-Address-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "19y8hhb7hywyfpmiws1wwnkx2hw2mqzj824hwv55wryb9q8g87im"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/Mail-RFC822-Address")
+ (synopsis
+ "Perl extension for validating email addresses according to RFC822")
+ (description
+ "@code{Mail::RFC822::Address} validates email addresses against the
+grammar described in RFC 822 using regular expressions.")
+ (license license:expat)))
+
(define-public perl-math-bezier
(package
(name "perl-math-bezier")