summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <[email protected]>2025-01-24 16:05:08 +0100
committerLudovic Courtès <[email protected]>2025-01-24 23:36:05 +0100
commit9f9e89a8ca0c18d0ca0292a3eb58d1da9a8cc119 (patch)
treeebc3354127b9be5ba7de64d399216384ed20413c
parent5ec09ac8673e9158172ba015b2082cc63517ea92 (diff)
gnu: linux-libre: Remove duplicate “[email protected]” package.
Fixes a regression in 5c2bcafd281fdd31b3dfec5a67ba85084c58cf60, which led to having two “[email protected]” packages on aarch64-linux, thus leading to a failure of the “fold-available-packages with/without cache” in ‘tests/packages.scm’. * gnu/packages/linux.scm (linux-libre-lts-arm64-generic): Check whether ‘linux-libre-lts-version’ is equal to ‘linux-libre-version’ and, if so, make it an alias for ‘linux-libre-arm64-generic’. Change-Id: I01e4d4ff9c66ffe1cb33dd781fba9f7f6b40e93e
-rw-r--r--gnu/packages/linux.scm60
1 files changed, 33 insertions, 27 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d691c0fe3b..77a53e4805 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012-2021, 2021-2024 Ludovic Courtès <[email protected]>
+;;; Copyright © 2012-2021, 2021-2025 Ludovic Courtès <[email protected]>
;;; Copyright © 2013, 2014, 2015, 2016 Andreas Enge <[email protected]>
;;; Copyright © 2012 Nikita Karetnikov <[email protected]>
;;; Copyright © 2014, 2015, 2016, 2017, 2018, 2019, 2020 Mark H Weaver <[email protected]>
@@ -1268,32 +1268,38 @@ Linux kernel. It has been modified to remove all non-free binary blobs.")
(default-extra-linux-options linux-libre-version))))
(define-public linux-libre-lts-arm64-generic
- (make-linux-libre* linux-libre-lts-version
- linux-libre-lts-gnu-revision
- linux-libre-lts-source
- '("aarch64-linux")
- #:defconfig "defconfig"
- #:extra-version "arm64-generic"
- #:extra-options
- (append
- `(;; Provide support for ath9k wireless
- ("CONFIG_ATH9K_HTC" . m)
- ;; needed to fix the RTC on rockchip platforms
- ("CONFIG_RTC_DRV_RK808" . #t)
- ;; Pinebook display, battery, charger and usb
- ("CONFIG_DRM_ANALOGIX_ANX6345" . m)
- ("CONFIG_CHARGER_AXP20X" . m)
- ("CONFIG_INPUT_AXP20X_PEK" . m)
- ("CONFIG_CHARGER_AXP20X" . m)
- ("CONFIG_BATTERY_AXP20X" . m)
- ("CONFIG_PINCTRL_AXP209" . m)
- ("CONFIG_AXP20X_POWER" . m)
- ("CONFIG_AXP20X_ADC" . m)
- ;; Pinebook PRO battery and sound support
- ("CONFIG_BATTERY_CW2015" . m)
- ("CONFIG_CHARGER_GPIO" . m)
- ("CONFIG_SND_SOC_ES8316" . m))
- (default-extra-linux-options linux-libre-lts-version))))
+ (if (string=? linux-libre-lts-version linux-libre-version)
+
+ ;; Make it a strict alias so that the user interface does not see two
+ ;; packages with the exact same name and version.
+ linux-libre-arm64-generic
+
+ (make-linux-libre* linux-libre-lts-version
+ linux-libre-lts-gnu-revision
+ linux-libre-lts-source
+ '("aarch64-linux")
+ #:defconfig "defconfig"
+ #:extra-version "arm64-generic"
+ #:extra-options
+ (append
+ `( ;; Provide support for ath9k wireless
+ ("CONFIG_ATH9K_HTC" . m)
+ ;; needed to fix the RTC on rockchip platforms
+ ("CONFIG_RTC_DRV_RK808" . #t)
+ ;; Pinebook display, battery, charger and usb
+ ("CONFIG_DRM_ANALOGIX_ANX6345" . m)
+ ("CONFIG_CHARGER_AXP20X" . m)
+ ("CONFIG_INPUT_AXP20X_PEK" . m)
+ ("CONFIG_CHARGER_AXP20X" . m)
+ ("CONFIG_BATTERY_AXP20X" . m)
+ ("CONFIG_PINCTRL_AXP209" . m)
+ ("CONFIG_AXP20X_POWER" . m)
+ ("CONFIG_AXP20X_ADC" . m)
+ ;; Pinebook PRO battery and sound support
+ ("CONFIG_BATTERY_CW2015" . m)
+ ("CONFIG_CHARGER_GPIO" . m)
+ ("CONFIG_SND_SOC_ES8316" . m))
+ (default-extra-linux-options linux-libre-lts-version)))))
(define-public linux-libre-arm64-generic-5.10
(make-linux-libre* linux-libre-5.10-version