summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-20 23:33:02 +0000
committerSharlatan Hellseher <[email protected]>2024-12-30 15:07:41 +0000
commit8fe36b77e0ef64ec1346a848ec71d9bb95a3f6a0 (patch)
tree12f817869a789f33e8c18bd6458bb639c832fcb5
parent621b2cee60f50ae249acff554bd9706c05784db1 (diff)
gnu: python-specutils: Fix build.
* gnu/packages/astronomy.scm (python-specutils): [arguments] <test-flags>: Skip one more test. <phases>: Remove 'relax-requirements. Change-Id: Iba3837d8d87ece1e97f954ffb20afdbfd6e05654
-rw-r--r--gnu/packages/astronomy.scm24
1 files changed, 13 insertions, 11 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index cf636c83f3..5f15ec62aa 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -4952,25 +4952,27 @@ of axis order, spatial projections, and spectral units that exist in the wild.
(build-system pyproject-build-system)
(arguments
(list
- ;; Disabling test requiring access to download
- ;; <https://datacenter.iers.org/data/9/finals2000A.all>.
- ;; XXX: Check if test data may be packed as standalone package.
- #:test-flags #~(list "-k" "not test_create_spectral_axis")
+ #:test-flags
+ #~(list "-k" (string-join
+ (list
+ ;; Disabling test requiring access to download
+ ;; <https://datacenter.iers.org/data/9/finals2000A.all>.
+ ;; XXX: Check if test data may be packed as standalone
+ ;; package.
+ "not test_create_spectral_axis"
+ ;; ValueError: Expected the following order of world
+ ;; arguments: SpectralCoord
+ "test_wcs_transformations")
+ " and not "))
#:phases
#~(modify-phases %standard-phases
- (add-after 'unpack 'relax-requirements
- (lambda _
- (substitute* "setup.cfg"
- ;; numpy>=1.24
- (("1.24") "1.23.2"))))
(add-before 'check 'set-home-env
(lambda _
;; Tests require HOME to be set.
;; Permission denied: '/homeless-shelter'
(setenv "HOME" "/tmp"))))))
(propagated-inputs
- (list ;; python-stdatamodels ; cycle with python-synphot, optional.
- python-asdf
+ (list python-asdf
python-asdf-astropy
python-astropy
python-gwcs