summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2024-12-25 21:32:49 +0200
committerEfraim Flashner <[email protected]>2025-01-06 12:19:17 +0200
commit8d35ef56522c104edf48c4337d03515027ebff90 (patch)
tree03cfa6def3e0402841b2c5bed4bfa0517f7c71da
parent0d4addabf74c1f087ec03a04e6e5e046c101835a (diff)
gnu: rbw: Update to 1.12.1.
* gnu/packages/rust-apps.scm (rbw): Update to 1.12.1. [cargo-inputs]: Add rust-axum-0.7, rust-open-5, rust-regex-1, rust-rustix-0.38, rust-urlencoding-2. Replace rust-base32-0.4 with 0.5, rust-tokio-tungstenite-0.21 with 0.23. Remove rust-async-trait-0.1, rust-nix-0.28. Change-Id: I23cfe2e54851c1c25f1b26c9aa70c1bd0c8c1351
-rw-r--r--gnu/packages/rust-apps.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index b8bc982c20..90d88a610e 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -3294,7 +3294,7 @@ runs a command whenever it detects modifications.")
(define-public rbw
(package
(name "rbw")
- (version "1.10.2")
+ (version "1.12.1")
(outputs '("out" "scripts"))
(source
(origin
@@ -3302,7 +3302,7 @@ runs a command whenever it detects modifications.")
(uri (crate-uri "rbw" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0dr0fv2iligj0svwk1d3lrx37s0g75lk8qwsg90dpfy5bn92hh3d"))
+ (base32 "175i4by97rnnpfxmy3cb8qlpf4ij793l37ln9q8n4fcq5dj84hs1"))
(modules '((guix build utils)))
(snippet
'(begin (substitute* "Cargo.toml"
@@ -3316,8 +3316,8 @@ runs a command whenever it detects modifications.")
("rust-anyhow" ,rust-anyhow-1)
("rust-argon2" ,rust-argon2-0.5)
("rust-arrayvec" ,rust-arrayvec-0.7)
- ("rust-async-trait" ,rust-async-trait-0.1)
- ("rust-base32" ,rust-base32-0.4)
+ ("rust-axum" ,rust-axum-0.7)
+ ("rust-base32" ,rust-base32-0.5)
("rust-base64" ,rust-base64-0.22)
("rust-block-padding" ,rust-block-padding-0.3)
("rust-cbc" ,rust-cbc-0.1)
@@ -3336,15 +3336,17 @@ runs a command whenever it detects modifications.")
("rust-is-terminal" ,rust-is-terminal-0.4)
("rust-libc" ,rust-libc-0.2)
("rust-log" ,rust-log-0.4)
- ("rust-nix" ,rust-nix-0.28)
+ ("rust-open" ,rust-open-5)
("rust-pbkdf2" ,rust-pbkdf2-0.12)
("rust-percent-encoding" ,rust-percent-encoding-2)
("rust-pkcs8" ,rust-pkcs8-0.10)
("rust-rand" ,rust-rand-0.8)
+ ("rust-regex" ,rust-regex-1)
("rust-region" ,rust-region-3)
("rust-reqwest" ,rust-reqwest-0.12)
("rust-rmpv" ,rust-rmpv-1)
("rust-rsa" ,rust-rsa-0.9)
+ ("rust-rustix" ,rust-rustix-0.38)
("rust-serde" ,rust-serde-1)
("rust-serde-json" ,rust-serde-json-1)
("rust-serde-path-to-error" ,rust-serde-path-to-error-0.1)
@@ -3357,9 +3359,10 @@ runs a command whenever it detects modifications.")
("rust-thiserror" ,rust-thiserror-1)
("rust-tokio" ,rust-tokio-1)
("rust-tokio-stream" ,rust-tokio-stream-0.1)
- ("rust-tokio-tungstenite" ,rust-tokio-tungstenite-0.21)
+ ("rust-tokio-tungstenite" ,rust-tokio-tungstenite-0.23)
("rust-totp-lite" ,rust-totp-lite-2)
("rust-url" ,rust-url-2)
+ ("rust-urlencoding" ,rust-urlencoding-2)
("rust-uuid" ,rust-uuid-1)
("rust-zeroize" ,rust-zeroize-1))
#:phases