summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <[email protected]>2025-03-07 11:14:07 +0100
committerNicolas Goaziou <[email protected]>2025-03-07 11:40:26 +0100
commit8baf7e11ffb361221f5e038d185b6e4bdfea26af (patch)
treee656e967de72a3a0b5d980f71e95feae69615986
parentf634fc01ef79d541441c7391ca9f52c71e7748c7 (diff)
gnu: asymptote: Update to 3.01.
* gnu/packages/plotutils.scm (asymptote): Update to 3.01. [arguments]<#:phases>: Use dynamic GC library. [native-inputs]: Remove autoconf, Add autoconf-2.71. Change-Id: Ia2a3759c411f35cae4169c148427ef48f9e5c683
-rw-r--r--gnu/packages/plotutils.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index b34dfd571f..50c7918f00 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <[email protected]>
;;; Copyright © 2015 Eric Bavier <[email protected]>
-;;; Copyright © 2016-2024 Nicolas Goaziou <[email protected]>
+;;; Copyright © 2016-2025 Nicolas Goaziou <[email protected]>
;;; Copyright © 2018 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2020 Maxim Cournoyer <[email protected]>
;;; Copyright © 2022 Antero Mejr <[email protected]>
@@ -67,14 +67,14 @@
(define-public asymptote
(package
(name "asymptote")
- (version "2.95")
+ (version "3.01")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/asymptote/"
version "/asymptote-" version ".src.tgz"))
(sha256
- (base32 "1rvqmjp6gich2fvxgl2d31d84z31zkkd4abmh1dvrpdn5k84yq0m"))
+ (base32 "115hjza0ic2mh3y2qjkvzpsx8cpy0yghklpbv8qhdgznqc5001bs"))
(modules '((guix build utils)))
(snippet
;; Remove bundled RapidJSON.
@@ -85,7 +85,7 @@
;; "help" command in interactive mode, so adding a "doc" output is not
;; currently useful.
(native-inputs
- (list autoconf
+ (list autoconf-2.71
automake
bison
boost
@@ -145,6 +145,7 @@
(add-after 'unpack 'locate-tirpc
(lambda* (#:key inputs #:allow-other-keys)
(substitute* (list "configure.ac")
+ (("GCLIB=\".*/libgc.a\"") "GCLIB=\"-lgc\"")
(("/usr/include/tirpc")
(search-input-directory inputs "include/tirpc")))))
(add-after 'unpack 'unbundle-rapidjson