summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-02 22:55:49 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:37 +0000
commit85465e73e91e22bc68cd157094d34a620a9bf8bb (patch)
tree817b811059100b4b679f1e34698cf5303d23d95a
parent519f6436362a3c723c94347a9f6eba9e8cb2d44e (diff)
gnu: go-github-com-rivo-uniseg: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-rivo-uniseg): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: I949ac20c547ec55a59b445c28ad868af36d70f18
-rw-r--r--gnu/packages/golang-xyz.scm24
-rw-r--r--gnu/packages/golang.scm22
2 files changed, 24 insertions, 22 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index b4fc25931d..fced56578d 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -10814,6 +10814,30 @@ routines querying a database but without sending too much queries in order to
not overload the given database.")
(license license:expat)))
+(define-public go-github-com-rivo-uniseg
+ (package
+ (name "go-github-com-rivo-uniseg")
+ (version "0.4.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rivo/uniseg")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0nlcqyvq4vhq3hqhk84h6fp0jbqkjj88kcpcl853yr7sh4sisdxc"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/rivo/uniseg"))
+ (home-page "https://github.com/rivo/uniseg")
+ (synopsis "Unicode Text Segmentation for Go")
+ (description
+ "This package implements Unicode Text Segmentation according to
+@url{https://unicode.org/reports/tr29/, Unicode Standard Annex #29}.")
+ (license license:expat)))
+
(define-public go-github-com-rogpeppe-fastuuid
(package
(name "go-github-com-rogpeppe-fastuuid")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 5f719c252f..3c916dd0c2 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4519,28 +4519,6 @@ programming language.")
parser.")
(license license:bsd-2)))
-(define-public go-github-com-rivo-uniseg
- (package
- (name "go-github-com-rivo-uniseg")
- (version "0.4.7")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/rivo/uniseg")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0nlcqyvq4vhq3hqhk84h6fp0jbqkjj88kcpcl853yr7sh4sisdxc"))))
- (build-system go-build-system)
- (arguments '(#:import-path "github.com/rivo/uniseg"))
- (home-page "https://github.com/rivo/uniseg")
- (synopsis "Unicode Text Segmentation for Go")
- (description
- "This package implements Unicode Text Segmentation according to
-@url{https://unicode.org/reports/tr29/, Unicode Standard Annex #29}.")
- (license license:expat)))
-
(define-public go-github-com-mtibben-percent
(package
(name "go-github-com-mtibben-percent")