summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Abramov via Guix-patches via <[email protected]>2024-11-21 12:25:56 +0000
committerChristopher Baines <[email protected]>2025-02-25 10:57:49 +0000
commit81e99a5caae91dcedff182bad008a2c815924ae7 (patch)
tree716a8c75833e5bb9deade809ef6b0853f7437837
parentada3baa1b33bf88a74efcd6668a0ec48190a90c8 (diff)
gnu: dovecot: Set moduledir to global directory.
* gnu/packages/mail.scm (dovecot)[arguments]: Add configure-flag to set moduledir. Adjust custom 'install phase to override moduledir so it successfully installs. Change-Id: I2614b2609f26f8ca2d8a97ab234f0041b86b8542 Signed-off-by: Christopher Baines <[email protected]>
-rw-r--r--gnu/packages/mail.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 7111f19046..cffbca087a 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -2156,7 +2156,8 @@ facilities for checking incoming mail.")
`(#:configure-flags '("--sysconfdir=/etc"
"--localstatedir=/var"
"--with-sqlite" ; not auto-detected
- "--with-lucene") ; not auto-detected
+ "--with-lucene"
+ "--with-moduledir=/usr/lib/dovecot") ; not auto-detected
;; The -rdynamic linker flag is needed for the backtrace() function to
;; have symbol names rather than just addresses. Dovecot's tests rely
;; on this, see https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=962630.
@@ -2176,9 +2177,12 @@ facilities for checking incoming mail.")
"src/lib-smtp/test-bin/sendmail-success.sh")
(("cat") (which "cat")))))
(replace 'install
- (lambda* (#:key make-flags #:allow-other-keys)
+ (lambda* (#:key outputs make-flags #:allow-other-keys)
+ ;; The .la files don't like having the moduledir moved.
+ (for-each delete-file (find-files "." "\\.la"))
;; Simple hack to avoid installing a trivial README in /etc.
(apply invoke "make" "install" "sysconfdir=/tmp/bogus"
+ (string-append "moduledir=" (assoc-ref outputs "out") "/lib/dovecot")
make-flags))))))
(home-page "https://www.dovecot.org")
(synopsis "Secure POP3/IMAP server")