summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-07 13:53:42 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:41 +0000
commit7de5bbcc91d827c93417e1d030087ef57fb25f88 (patch)
tree6f3dd6d4395b22ae4b7586c14060394962b6b34c
parentebabe2ed817603b430e99e8b5c1807001329bac8 (diff)
gnu: go-github-com-apparentlymart-go-textseg-autoversion: Update to 1.3.0.
* gnu/packages/golang-xyz.scm (go-github-com-apparentlymart-go-textseg-autoversion): Update to 1.3.0. Do not inherit from go-github-com-apparentlymart-go-textseg-v13. [arguments] <skip-build?>: As no go files in project's root. [propagated-inputs]: Add go-github-com-apparentlymart-go-textseg-v9, go-github-com-apparentlymart-go-textseg-v10, go-github-com-apparentlymart-go-textseg-v11, go-github-com-apparentlymart-go-textseg-v12, go-github-com-apparentlymart-go-textseg-v13, and go-github-com-apparentlymart-go-textseg-v15. [synopsis]: Add it. [description]: Likewise. Change-Id: I4d553ccfd1880455d77231042cd5a805a0613c48
-rw-r--r--gnu/packages/golang-xyz.scm33
1 files changed, 30 insertions, 3 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index cc16a06bd5..00b86e151b 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1141,11 +1141,38 @@ cluster segmentation algorithm.")
(define-public go-github-com-apparentlymart-go-textseg-autoversion
(package
- (inherit go-github-com-apparentlymart-go-textseg-v13)
(name "go-github-com-apparentlymart-go-textseg-autoversion")
+ (version "1.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/apparentlymart/go-textseg")
+ (commit (go-version->git-ref version #:subdir "autoversion"))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1j7vm09cd36wm4z986qz5am3rk242v52amcapwbdbkbgzx2kqfkm"))))
+ (build-system go-build-system)
(arguments
- '(#:unpack-path "github.com/apparentlymart/go-textseg/autoversion"
- #:import-path "github.com/apparentlymart/go-textseg/autoversion/textseg"))))
+ (list
+ #:skip-build? #t
+ #:import-path "github.com/apparentlymart/go-textseg/autoversion"
+ #:unpack-path "github.com/apparentlymart/go-textseg"))
+ (propagated-inputs
+ (list go-github-com-apparentlymart-go-textseg-v9
+ go-github-com-apparentlymart-go-textseg-v10
+ go-github-com-apparentlymart-go-textseg-v11
+ go-github-com-apparentlymart-go-textseg-v12
+ go-github-com-apparentlymart-go-textseg-v13
+ go-github-com-apparentlymart-go-textseg-v15))
+ (home-page "https://github.com/apparentlymart/go-textseg")
+ (synopsis "Wrap go-textesg based on the Unicode Golang version")
+ (description
+ "This package is a wrapper around each of the the
+Unicode-version-specific textseg implementations that selects an
+implementation automatically based on the Unicode version of the Go standard
+library that it's being built against.")
+ (license (list license:expat license:unicode license:asl2.0))))
(define-public go-github-com-arbovm-levenshtein
(package