summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <[email protected]>2025-01-23 15:43:46 +0100
committerRicardo Wurmus <[email protected]>2025-01-23 15:59:20 +0100
commit77f676ed5daeb9b958dd79aa15c6d6b591e56091 (patch)
tree0c57e4b76129db10dce4b9777580fdd3076d59ac
parent916d58635ac574cc04dcd4605a0bc58c6db625c4 (diff)
gnu: Add r-nanotime.
* gnu/packages/cran.scm (r-nanotime): New variable. Change-Id: I2602ec9b6225692d3ed3ed336f502edb22919851
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 0028cd5950..f79cb7d202 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -39482,6 +39482,31 @@ book @emph{Nondetects and Data Analysis: Statistics for Censored
Environmental Data}.")
(license license:gpl2+)))
+(define-public r-nanotime
+ (package
+ (name "r-nanotime")
+ (version "0.3.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "nanotime" version))
+ (sha256
+ (base32 "19q8xklkdp8jsq1hjj78wzr0q00fy8z5p2skyz2xlzvam3555pnb"))))
+ (properties
+ `((upstream-name . "nanotime")
+ (updater-extra-native-inputs . ("tzdata-for-tests"))))
+ (build-system r-build-system)
+ (propagated-inputs (list r-bit64 r-rcpp r-rcppcctz r-rcppdate r-zoo))
+ (native-inputs (list r-tinytest tzdata-for-tests))
+ (home-page "https://github.com/eddelbuettel/nanotime")
+ (synopsis "Nanosecond-resolution time support for R")
+ (description
+ "Full 64-bit resolution date and time functionality with nanosecond
+granularity is provided, with easy transition to and from the standard POSIXct
+type. Three additional classes offer interval, period and duration
+functionality for nanosecond-resolution timestamps.")
+ (license license:gpl2+)))
+
(define-public r-naturalsort
(package
(name "r-naturalsort")