summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <[email protected]>2024-07-13 10:20:42 +0200
committerLiliana Marie Prikler <[email protected]>2025-03-02 20:31:31 +0100
commit75a8333005c92ed751643c64583fa4643299b3a2 (patch)
tree31e0852c79d617ffba5de6b01d54714d7f76025e
parent7f5dae4c11caecc33df01a4abacc171bf03f1930 (diff)
gnu: epiphany: Update to 46.3.
* gnu/packages/gnome.scm (epiphany): Update to 46.3. * gnu/packages/patches/epiphany-fix-encoding-test.patch: Delete patch. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gnome.scm5
-rw-r--r--gnu/packages/patches/epiphany-fix-encoding-test.patch40
3 files changed, 2 insertions, 44 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 00bbc8f128..3675524045 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1244,7 +1244,6 @@ dist_patch_DATA = \
%D%/packages/patches/enblend-enfuse-reproducible.patch \
%D%/packages/patches/enjarify-setup-py.patch \
%D%/packages/patches/enlightenment-fix-setuid-path.patch \
- %D%/packages/patches/epiphany-fix-encoding-test.patch \
%D%/packages/patches/ergodox-firmware-fix-json-target.patch \
%D%/packages/patches/ergodox-firmware-fix-numpad.patch \
%D%/packages/patches/ericw-tools-add-check-for-sse2-in-light.cc.patch \
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d40bd25fec..ba24f4f36f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7257,7 +7257,7 @@ almost all of them.")
(define-public epiphany
(package
(name "epiphany")
- (version "44.8")
+ (version "46.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/epiphany/"
@@ -7265,8 +7265,7 @@ almost all of them.")
"epiphany-" version ".tar.xz"))
(sha256
(base32
- "1n3df2skvgmjw9sybhn811l4b58ibwxc0dc208wpvxg060pyhpfk"))
- (patches (search-patches "epiphany-fix-encoding-test.patch"))))
+ "0ml64ymz53q6583ijl5msq1zabvs3my1gl74xg2py4a9chhavqd9"))))
(build-system meson-build-system)
(arguments
(list
diff --git a/gnu/packages/patches/epiphany-fix-encoding-test.patch b/gnu/packages/patches/epiphany-fix-encoding-test.patch
deleted file mode 100644
index a491053d06..0000000000
--- a/gnu/packages/patches/epiphany-fix-encoding-test.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From 3b334ba2c9dc869dc84e4b2f84d00df972c0e734 Mon Sep 17 00:00:00 2001
-From: Michael Catanzaro <[email protected]>
-Date: Fri, 10 Nov 2023 15:36:14 -0600
-Subject: [PATCH] Fix encodings test when running in non-English locale
-
-Let's force use of the C.UTF-8 locale, so the value of the collation key
-does not depend on the host locale.
-
-Fixes #1842
-
-Part-of: <https://gitlab.gnome.org/GNOME/epiphany/-/merge_requests/1413>
----
- tests/ephy-encodings-test.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/tests/ephy-encodings-test.c b/tests/ephy-encodings-test.c
-index a3ea7e781d..992d80d2c2 100644
---- a/tests/ephy-encodings-test.c
-+++ b/tests/ephy-encodings-test.c
-@@ -44,7 +44,7 @@ test_ephy_encodings_create (void)
- g_assert_cmpstr (ephy_encoding_get_encoding (encoding), ==, "UTF-8");
- g_assert_cmpstr (ephy_encoding_get_title (encoding), ==, "Unicode (UTF-8)");
- g_assert_cmpstr (ephy_encoding_get_title_elided (encoding), ==, "Unicode (UTF-8)");
-- g_assert_cmpstr (ephy_encoding_get_collation_key (encoding), ==, "\311\263\307\276\307\205\305\271\310\215\306\202\306\216\311\263\311\250\306\245\305\237\001\035\035\035\035\035\035\035\035\035\035\035\001\007\002\002\002\002\002\002\007\007\007\002\001\001\346\244\273\001\346\215\264\001\346\211\243\001\346\204\235\001\346\216\257\001\346\205\217\001\346\206\212\001\343\265\233\001\343\265\242\001\346\244\273\001\346\244\231\001\346\234\257\001\343\265\247\001\345\277\241\001\343\265\243");
-+ g_assert_cmpstr (ephy_encoding_get_collation_key (encoding), ==, "Unicode (UTF-8)");
- g_assert_cmpint (ephy_encoding_get_language_groups (encoding), ==, LG_UNICODE);
-
- g_object_unref (encoding);
-@@ -80,7 +80,7 @@ main (int argc,
- int ret;
-
- gtk_test_init (&argc, &argv);
-- setlocale (LC_ALL, "");
-+ setlocale (LC_ALL, "C.UTF-8");
-
- ephy_debug_init ();
-
---
-GitLab
-