summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-22 01:15:40 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:14 +0000
commit74a939a394401c12a4019d8c2dc304497ccb4b43 (patch)
treec6ef93b53da7b81fa2f8bfc05697f7914679b96a
parentf49382b19a0cf7ef730ee13047a9aba2671508c6 (diff)
gnu: Add go-rsc-io-pdf.
* gnu/packages/golang-build.scm (go-rsc-io-pdf): New variable. Change-Id: I518233cc328f37632462b452f27e7c109ddbbf1f
-rw-r--r--gnu/packages/golang-build.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index 950138f9e0..39949da850 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -1184,6 +1184,29 @@ data. It is a successor to @code{go-github-com-golang-protobuf} with an
improved and cleaner API.")
(license license:bsd-3)))
+(define-public go-rsc-io-pdf
+ (package
+ (name "go-rsc-io-pdf")
+ (version "0.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rsc/pdf")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "01qjjwa8nn5a2jzd360xqg5zc8s0i2fpwcn2w2g6y2jgn9wl8x84"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:tests? #f
+ #:import-path "rsc.io/pdf"))
+ (home-page "https://rsc.io/pdf")
+ (synopsis "PDF reader for Golang")
+ (description "Package pdf implements reading of PDF files.")
+ (license license:bsd-3)))
+
;;;
;;; Executables:
;;;