summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2025-01-03 11:21:49 +0200
committerEfraim Flashner <[email protected]>2025-01-06 12:22:42 +0200
commit72f3b76247f4a10f9ca2d7cbde47da4a3db24fad (patch)
tree9133efd740512ce1b14a489f09244aa2151c8c63
parent3f71757ad5c1ea1c9749126015f5aab17a41cd18 (diff)
gnu: Add rust-blowfish-0.8.
* gnu/packages/crates-crypto.scm (rust-blowfish-0.8): New variable. Change-Id: I38a854f478b1459687d961b509d87bf38e827c56
-rw-r--r--gnu/packages/crates-crypto.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 7be34ac426..9a3d8d0f0c 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -892,6 +892,24 @@ and block modes.")
(description "Blowfish block cipher")
(license (list license:expat license:asl2.0))))
+(define-public rust-blowfish-0.8
+ (package
+ (inherit rust-blowfish-0.9)
+ (name "rust-blowfish")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "blowfish" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1ax736islxcbghc2lqq4vy7zn6qdigrls71lwg11m3743pyg6gzy"))))
+ (arguments
+ `(#:cargo-inputs (("rust-byteorder" ,rust-byteorder-1)
+ ("rust-cipher" ,rust-cipher-0.3)
+ ("rust-opaque-debug" ,rust-opaque-debug-0.3))
+ #:cargo-development-inputs (("rust-cipher" ,rust-cipher-0.3))))))
+
(define-public rust-botan-0.10
(package
(name "rust-botan")