summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-11 15:23:11 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:58 +0000
commit7009476627368d1a9a24b8443ddc21fbfbc6b726 (patch)
treeb29b721708fa6e9055f2e530e930a2969cae8c4d
parent0af5e34f2eb831eadda38986a46cab97287edf91 (diff)
gnu: go-github-com-99designs-keyring: Simplify.
* gnu/packages/golang-crypto.scm (go-github-com-99designs-keyring) [arguments] <test-flags>: Move skip tests logic here. <phases>: Remove 'disable-failing-tests. Change-Id: I69dc7a85963632c430bfc0f54caacaa371675bcd
-rw-r--r--gnu/packages/golang-crypto.scm28
1 files changed, 9 insertions, 19 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 0326382c25..b5340bc7a7 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -198,25 +198,15 @@ primitives.")
(arguments
(list
#:import-path "github.com/99designs/keyring"
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'disable-failing-tests
- (lambda* (#:key tests? unpack-path #:allow-other-keys)
- (with-directory-excursion (string-append "src/" unpack-path)
- (substitute* (find-files "." "\\_test.go$")
- ;; Disable test requring running DBus.
- (("TestLibSecretKeysWhenEmpty")
- "OffTestLibSecretKeysWhenEmpty")
- (("TestLibSecretKeysWhenNotEmpty")
- "OffTestLibSecretKeysWhenNotEmpty")
- (("TestLibSecretGetWhenEmpty")
- "OffTestLibSecretGetWhenEmpty")
- (("TestLibSecretGetWhenNotEmpty")
- "OffTestLibSecretGetWhenNotEmpty")
- (("TestLibSecretRemoveWhenEmpty")
- "OffTestLibSecretRemoveWhenEmpty")
- (("TestLibSecretRemoveWhenNotEmpty")
- "OffTestLibSecretRemoveWhenNotEmpty"))))))))
+ #:test-flags
+ #~(list "-skip" (string-join
+ (list "TestLibSecretKeysWhenEmpty"
+ "TestLibSecretKeysWhenNotEmpty"
+ "TestLibSecretGetWhenEmpty"
+ "TestLibSecretGetWhenNotEmpty"
+ "TestLibSecretRemoveWhenEmpty"
+ "TestLibSecretRemoveWhenNotEmpty")
+ "|"))))
(native-inputs
(list gnupg go-github-com-stretchr-testify password-store))
(propagated-inputs