summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2024-12-04 17:37:16 +0200
committerEfraim Flashner <[email protected]>2025-01-06 12:14:45 +0200
commit6f3e837ee7aea4dbf4ef1690ff2350a224fffa94 (patch)
tree7b64b3c83e7ade18aac92564c4ec901cf75a5d5b
parent1fefe5bc6ccd912690d42cf78ba959dc8e228aa1 (diff)
gnu: Add rust-rustls-native-certs-0.8.
* gnu/packages/crates-tls.scm (rust-rustls-native-certs-0.8): New variable. (rust-rustls-native-certs-0.7): Inherit from rust-rustls-native-certs-0.8. Change-Id: I73d9eb0fb4e3cb381b12dcc740d16a47767922a1
-rw-r--r--gnu/packages/crates-tls.scm40
1 files changed, 34 insertions, 6 deletions
diff --git a/gnu/packages/crates-tls.scm b/gnu/packages/crates-tls.scm
index 4480fa9052..b36810c886 100644
--- a/gnu/packages/crates-tls.scm
+++ b/gnu/packages/crates-tls.scm
@@ -1633,26 +1633,25 @@ grammars and BER/DER encodings, for example.")
(substitute* "Cargo.toml"
(("0\\.19\\.0") "*")))))))))
-(define-public rust-rustls-native-certs-0.7
+(define-public rust-rustls-native-certs-0.8
(package
(name "rust-rustls-native-certs")
- (version "0.7.3")
+ (version "0.8.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "rustls-native-certs" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1r9ib5gwkfci2wbqnbh44nigvrfgxs4n1x89js82w97dxsab7gz5"))))
+ (base32 "1ls7laa3748mkn23fmi3g4mlwk131lx6chq2lyc8v2mmabfz5kvz"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-test-flags '("--release" "--"
"--skip=test_contains_most_roots_known_by_mozilla")
#:cargo-inputs (("rust-openssl-probe" ,rust-openssl-probe-0.1)
- ("rust-rustls-pemfile" ,rust-rustls-pemfile-2)
("rust-rustls-pki-types" ,rust-rustls-pki-types-1)
("rust-schannel" ,rust-schannel-0.1)
- ("rust-security-framework" ,rust-security-framework-2))
+ ("rust-security-framework" ,rust-security-framework-3))
#:cargo-development-inputs (("rust-ring" ,rust-ring-0.17)
("rust-rustls" ,rust-rustls-0.23)
("rust-rustls-webpki" ,rust-rustls-webpki-0.102)
@@ -1661,12 +1660,41 @@ grammars and BER/DER encodings, for example.")
("rust-untrusted" ,rust-untrusted-0.9)
("rust-webpki-roots" ,rust-webpki-roots-0.26)
("rust-x509-parser" ,rust-x509-parser-0.16))))
- (home-page "https://github.com/ctz/rustls-native-certs")
+ (home-page "https://github.com/rustls/rustls-native-certs")
(synopsis "Use the platform native certificate store with rustls")
(description "@code{rustls-native-certs} allows rustls to use the platform
native certificate store.")
(license (list license:asl2.0 license:isc license:expat))))
+(define-public rust-rustls-native-certs-0.7
+ (package
+ (inherit rust-rustls-native-certs-0.8)
+ (name "rust-rustls-native-certs")
+ (version "0.7.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rustls-native-certs" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1r9ib5gwkfci2wbqnbh44nigvrfgxs4n1x89js82w97dxsab7gz5"))))
+ (arguments
+ `(#:cargo-test-flags '("--release" "--"
+ "--skip=test_contains_most_roots_known_by_mozilla")
+ #:cargo-inputs (("rust-openssl-probe" ,rust-openssl-probe-0.1)
+ ("rust-rustls-pemfile" ,rust-rustls-pemfile-2)
+ ("rust-rustls-pki-types" ,rust-rustls-pki-types-1)
+ ("rust-schannel" ,rust-schannel-0.1)
+ ("rust-security-framework" ,rust-security-framework-2))
+ #:cargo-development-inputs (("rust-ring" ,rust-ring-0.17)
+ ("rust-rustls" ,rust-rustls-0.23)
+ ("rust-rustls-webpki" ,rust-rustls-webpki-0.102)
+ ("rust-serial-test" ,rust-serial-test-3)
+ ("rust-tempfile" ,rust-tempfile-3)
+ ("rust-untrusted" ,rust-untrusted-0.9)
+ ("rust-webpki-roots" ,rust-webpki-roots-0.26)
+ ("rust-x509-parser" ,rust-x509-parser-0.16))))))
+
(define-public rust-rustls-native-certs-0.6
(package
(inherit rust-rustls-native-certs-0.7)