summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-11-25 20:23:22 +0000
committerSharlatan Hellseher <[email protected]>2024-12-13 20:23:32 +0000
commit621f1231abfa7b8fcaade99840660fbdf7f8d647 (patch)
tree525394b785ac62b17d4a987f861aadd1b62679d9
parent4e1e9625a482c53ace15d10701b1a9ed2428e4a2 (diff)
gnu: python-icecream: Adjust inputs.
* gnu/packages/python-xyz.scm (python-icecream) [native-inputs]: Add python-setuptools and python-wheel. Change-Id: I5113590baf0ba80dae2b8931870c65dba9358cb7
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c39aff453a..b70fdccdfc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -38789,9 +38789,16 @@ forms, and about 300,000 distinct lemmas.")
;; https://github.com/gruns/icecream/issues/144
(string-append "not testEnableDisable"
" and not testSingledispatchArgumentToString"))))
- (propagated-inputs (list python-asttokens python-colorama python-executing
- python-pygments))
- (native-inputs (list python-hypothesis python-pytest))
+ (native-inputs
+ (list python-hypothesis
+ python-pytest
+ python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-asttokens
+ python-colorama
+ python-executing
+ python-pygments))
(home-page "https://github.com/gruns/icecream")
(synopsis
"Single function call to debug variables, expressions, and program execution")