summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-27 20:53:43 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:30 +0000
commit61fd903f4bc4c485339c33a94b4baa7f00f28824 (patch)
treea70a96d34866d7f43a40e8c752f26c074064ca78
parentfb0eefc221ec987ef1c008186ce9482462f84320 (diff)
gnu: Add go-github-com-karrick-golf.
* gnu/packages/golang-xyz.scm (go-github-com-karrick-golf): New variable. Change-Id: I7ee826d5f8f293d2f276a75a18a7d2400b3ebae7
-rw-r--r--gnu/packages/golang-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 26f0ec4bee..8b6f53a2b0 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -6836,6 +6836,35 @@ customized globally.")
"This package provides functions to read and traverse directory trees.")
(license license:bsd-2)))
+(define-public go-github-com-karrick-golf
+ (package
+ (name "go-github-com-karrick-golf")
+ (version "1.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/karrick/golf")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0iskalk32zqiwwrfmi9lcd1s69xgn3yl056xcm5q4y5znbs96fac"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/karrick/golf"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-examples
+ (lambda* (#:key import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (delete-file-recursively "example")))))))
+ (home-page "https://github.com/karrick/golf")
+ (synopsis "Light-weight long and short command line option parser")
+ (description
+ "Go long flag: a light-weight long and short command line option parser.")
+ (license license:bsd-3)))
+
(define-public go-github-com-kballard-go-shellquote
;; No release, see <https://github.com/kballard/go-shellquote/issues/13>.
(let ((commit "95032a82bc518f77982ea72343cc1ade730072f0")