summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-11-26 15:31:28 +0000
committerSharlatan Hellseher <[email protected]>2024-12-13 20:28:36 +0000
commit5dfe277d0ad4f7f8447fccd6cf72cc06858187fb (patch)
treefd57dd40e6972cd190de6a0f9cb3ab89909dd675
parentee4d2d4b52f5b36f8f41047315b1e6fdbdc48866 (diff)
gnu: python-aiofiles: Update to 24.1.0.
* gnu/packages/python-xyz.scm (python-aiofiles): Update to 24.1.0. [build-system]: Swap to pyproject-build-system. [native-inputs]: Add python-hatchling, python-hatch-vcs, python-pytest, and python-pytest-asyncio. Change-Id: I8888c4aa1b161f7f8438ce9a2c84a884ecfdcbd3
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7712a62234..2c3d432e5b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -34009,15 +34009,20 @@ process.")
(define-public python-aiofiles
(package
(name "python-aiofiles")
- (version "23.1.0")
+ (version "24.1.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "aiofiles" version))
(sha256
(base32
- "0d8n79slihf1lkbh2m6yw51rlq6n6vssljsdacbdpq0rkbglglpd"))))
- (build-system python-build-system)
+ "0v0namryb6acj9bkic5rcgbnb36njj601ws85q60z0d3wp4pb812"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-hatchling
+ python-hatch-vcs
+ python-pytest
+ python-pytest-asyncio))
(home-page "https://github.com/Tinche/aiofiles")
(synopsis "File support for @code{asyncio}")
(description "@code{python-aiofiles} is a library for handling local