summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <[email protected]>2025-01-07 01:24:15 +0100
committerDanny Milosavljevic <[email protected]>2025-01-07 01:37:29 +0100
commit5d9e839fce98c49a8db47422a050ce03d799fe02 (patch)
tree58191cb8de78fe7c504f1676f5dab95624689a67
parent1814aa769cd5588210587d39b5bbb5e34de7aed4 (diff)
gnu: python-mathics-core: Fix build.
* gnu/packages/maths.scm (python-mathics-core)[native-inputs]: Add python-setuptools, python-wheel. [arguments]<#:phases>[prepare-check]: Add phase. Change-Id: I09976b9f6a3a8a67c6f786dc5626ff1894fe5b37
-rw-r--r--gnu/packages/maths.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index e658918317..dfb43ef074 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -10687,13 +10687,17 @@ the Wolfram language.")
(substitute* "mathics/builtin/files_io/files.py"
(("https://raw.githubusercontent.com/Mathics3/mathics-core/master/README.rst")
(string-append (getcwd) "/README.rst")))))
+ (add-before 'check 'prepare-check
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ; Doesn't work: (add-installed-pythonpath inputs outputs)
+ (setenv "PYTHONPATH" (getcwd))))
(add-before 'check 'prepare-locales
(lambda _
;; Otherwise 210 tests fail because the real output would use
;; unicode arrow characters. With this, only 18 (symbolic) tests fail.
(setenv "MATHICS_CHARACTER_ENCODING" "ASCII"))))))
(build-system pyproject-build-system)
- (native-inputs (list python-pytest))
+ (native-inputs (list python-pytest python-setuptools python-wheel))
(inputs (list llvm))
(propagated-inputs (list python-mpmath
python-pint