summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex McGrath <[email protected]>2020-04-16 21:55:28 +0100
committerMathieu Othacehe <[email protected]>2020-04-27 18:22:56 +0200
commit58a361fef40f86d28938c7a964ca38032ff7f5a0 (patch)
treed870534469e0c79a3a952133fadb7e0bc80f404f
parentc53886a55a40e106740209cf587fef4e52226aae (diff)
gnu: Add wf-recorder.
* gnu/packages/video.scm (wf-recorder): New variable. Signed-off-by: Mathieu Othacehe <[email protected]>
-rw-r--r--gnu/packages/video.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 1ae678da85..e3d145a840 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -40,6 +40,7 @@
;;; Copyright © 2020 Brice Waegeneire <[email protected]>
;;; Copyright © 2020 Vincent Legoll <[email protected]>
;;; Copyright © 2020 Guillaume Le Vaillant <[email protected]>
+;;; Copyright © 2020 Alex McGrath <[email protected]>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4071,3 +4072,33 @@ With Peek, you simply place the Peek window over the area you want to record
and press \"Record\". Peek is optimized for generating animated GIFs, but you
can also directly record to WebM or MP4 if you prefer.")
(license license:gpl3+)))
+
+(define-public wf-recorder
+ (package
+ (name "wf-recorder")
+ (version "0.2.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ammen99/wf-recorder.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1cw6kpcbl33wh95pvy32xrsrm6kkk1awccr3phyh885xjs3b3iim"))))
+ (build-system meson-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("ffmpeg" ,ffmpeg)
+ ("pulseaudio" ,pulseaudio)
+ ("wayland" ,wayland)
+ ("wayland-protocols" ,wayland-protocols)
+ ("libx264" ,libx264)))
+ (home-page "https://github.com/ammen99/wf-recorder")
+ (synopsis "Screen recorder for wlroots-based compositors")
+ (description
+ "@code{wf-recorder} is a utility program for screen recording of
+wlroots-based compositors. More specifically, those that support
+@code{wlr-screencopy-v1} and @code{xdg-output}.")
+ (license license:expat)))