summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2024-12-26 20:52:23 +0200
committerEfraim Flashner <[email protected]>2025-01-06 12:19:33 +0200
commit584cf9c9333959b82bf0e818f487aa473fc7479e (patch)
treea9c02ce64dea216fc6cff90fdff4555e9d94d93c
parentf74b308e7cd45c5624867ffaf99ceda782ef6616 (diff)
gnu: rust-postgres: Move to (gnu packages crates-database).
* gnu/packages/crates-io.scm (rust-postgres-0.19, rust-postgres-derive-0.4, rust-postgres-protocol-0.6, rust-postgres-types-0.2): Move from here ... * gnu/packages/crates-database.scm: ... to here. Change-Id: I5d698ec0c3ba509f3c3f7e08cd812cba385ee2a8
-rw-r--r--gnu/packages/crates-database.scm124
-rw-r--r--gnu/packages/crates-io.scm123
2 files changed, 124 insertions, 123 deletions
diff --git a/gnu/packages/crates-database.scm b/gnu/packages/crates-database.scm
index 539659e9f0..63650ea871 100644
--- a/gnu/packages/crates-database.scm
+++ b/gnu/packages/crates-database.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2021 Nicolas Goaziou <[email protected]>
;;; Copyright © 2021 Léo Le Bouter <[email protected]>
;;; Copyright © 2021 Vinicius Monego <[email protected]>
+;;; Copyright © 2021 Domagoj Stolfa <[email protected]>
;;; Copyright © 2021, 2023, 2024 Efraim Flashner <[email protected]>
;;; Copyright © 2022 Aleksandr Vityazev <[email protected]>
;;; Copyright © 2023 Jaeme Sifat <[email protected]>
@@ -448,6 +449,129 @@ Diesel.")
libmysqlclient.")
(license (list license:expat license:asl2.0))))
+(define-public rust-postgres-0.19
+ (package
+ (name "rust-postgres")
+ (version "0.19.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "postgres" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1hnid1d78zrr8ph12lpvp5b2cpx2fsqqgqs2yn1q23c6g7jix1y7"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:tests? #f ; tests require postgres server.
+ #:cargo-inputs
+ (("rust-bytes" ,rust-bytes-1)
+ ("rust-fallible-iterator" ,rust-fallible-iterator-0.2)
+ ("rust-futures" ,rust-futures-0.3)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-tokio" ,rust-tokio-1)
+ ("rust-tokio-postgres" ,rust-tokio-postgres-0.7))
+ #:cargo-development-inputs
+ (("rust-criterion" ,rust-criterion-0.3))))
+ (home-page "https://github.com/sfackler/rust-postgres")
+ (synopsis "Native, synchronous PostgreSQL client")
+ (description
+ "This package provides a native, synchronous PostgreSQL client.")
+ (license license:expat)))
+
+(define-public rust-postgres-derive-0.4
+ (package
+ (name "rust-postgres-derive")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "postgres-derive" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0xqlf1gffy3q8hra3fm0vm9x8i5fkvi0qjl99d0xirxh3hidsmy8"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-syn" ,rust-syn-1))))
+ (home-page "https://github.com/sfackler/rust-postgres")
+ (synopsis "Internal crate used by postgres-types")
+ (description
+ "This is an internal crate used by postgres-types.")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-postgres-protocol-0.6
+ (package
+ (name "rust-postgres-protocol")
+ (version "0.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "postgres-protocol" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1wxzs78zvz00bh3bhbbp9hnq9hg77f8h5pzjmcy9481fsdq0ygpz"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-base64" ,rust-base64-0.13)
+ ("rust-byteorder" ,rust-byteorder-1)
+ ("rust-bytes" ,rust-bytes-1)
+ ("rust-fallible-iterator" ,rust-fallible-iterator-0.2)
+ ("rust-hmac" ,rust-hmac-0.10)
+ ("rust-md-5" ,rust-md-5-0.9)
+ ("rust-memchr" ,rust-memchr-2)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-sha2" ,rust-sha2-0.9)
+ ("rust-stringprep" ,rust-stringprep-0.1))))
+ (home-page "https://github.com/sfackler/rust-postgres")
+ (synopsis "Low level Postgres protocol APIs")
+ (description
+ "This package provides low level Postgres protocol APIs.")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-postgres-types-0.2
+ (package
+ (name "rust-postgres-types")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "postgres-types" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0brsqkydz0grfy60nc1d0hxa9jbpim0c7c52v467nrdpw4ql23s3"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-bit-vec" ,rust-bit-vec-0.6)
+ ("rust-bytes" ,rust-bytes-1)
+ ("rust-chrono" ,rust-chrono-0.4)
+ ("rust-eui48" ,rust-eui48-0.4)
+ ("rust-fallible-iterator" ,rust-fallible-iterator-0.2)
+ ("rust-geo-types" ,rust-geo-types-0.7)
+ ("rust-geo-types" ,rust-geo-types-0.6)
+ ("rust-postgres-derive" ,rust-postgres-derive-0.4)
+ ("rust-postgres-protocol" ,rust-postgres-protocol-0.6)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-time" ,rust-time-0.2)
+ ("rust-uuid" ,rust-uuid-0.8))))
+ (home-page "https://github.com/sfackler/rust-postgres")
+ (synopsis "Conversions between Rust and Postgres values")
+ (description
+ "This package provides a Rust implementation for conversions between Rust
+and Postgres values.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-rusqlite-0.32
(package
(name "rust-rusqlite")
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 9d6e3c97e4..ef04ef304f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -59007,129 +59007,6 @@ overloading without macros in Rust.")
(description "This package provides the implementation details for postcard.")
(license (list license:expat license:asl2.0))))
-(define-public rust-postgres-0.19
- (package
- (name "rust-postgres")
- (version "0.19.1")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "postgres" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1hnid1d78zrr8ph12lpvp5b2cpx2fsqqgqs2yn1q23c6g7jix1y7"))))
- (build-system cargo-build-system)
- (arguments
- `(#:tests? #f ; tests require postgres server.
- #:cargo-inputs
- (("rust-bytes" ,rust-bytes-1)
- ("rust-fallible-iterator" ,rust-fallible-iterator-0.2)
- ("rust-futures" ,rust-futures-0.3)
- ("rust-log" ,rust-log-0.4)
- ("rust-tokio" ,rust-tokio-1)
- ("rust-tokio-postgres" ,rust-tokio-postgres-0.7))
- #:cargo-development-inputs
- (("rust-criterion" ,rust-criterion-0.3))))
- (home-page "https://github.com/sfackler/rust-postgres")
- (synopsis "Native, synchronous PostgreSQL client")
- (description
- "This package provides a native, synchronous PostgreSQL client.")
- (license license:expat)))
-
-(define-public rust-postgres-derive-0.4
- (package
- (name "rust-postgres-derive")
- (version "0.4.0")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "postgres-derive" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "0xqlf1gffy3q8hra3fm0vm9x8i5fkvi0qjl99d0xirxh3hidsmy8"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs
- (("rust-proc-macro2" ,rust-proc-macro2-1)
- ("rust-quote" ,rust-quote-1)
- ("rust-syn" ,rust-syn-1))))
- (home-page "https://github.com/sfackler/rust-postgres")
- (synopsis "Internal crate used by postgres-types")
- (description
- "This is an internal crate used by postgres-types.")
- (license (list license:expat license:asl2.0))))
-
-(define-public rust-postgres-protocol-0.6
- (package
- (name "rust-postgres-protocol")
- (version "0.6.1")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "postgres-protocol" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1wxzs78zvz00bh3bhbbp9hnq9hg77f8h5pzjmcy9481fsdq0ygpz"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs
- (("rust-base64" ,rust-base64-0.13)
- ("rust-byteorder" ,rust-byteorder-1)
- ("rust-bytes" ,rust-bytes-1)
- ("rust-fallible-iterator" ,rust-fallible-iterator-0.2)
- ("rust-hmac" ,rust-hmac-0.10)
- ("rust-md-5" ,rust-md-5-0.9)
- ("rust-memchr" ,rust-memchr-2)
- ("rust-rand" ,rust-rand-0.8)
- ("rust-sha2" ,rust-sha2-0.9)
- ("rust-stringprep" ,rust-stringprep-0.1))))
- (home-page "https://github.com/sfackler/rust-postgres")
- (synopsis "Low level Postgres protocol APIs")
- (description
- "This package provides low level Postgres protocol APIs.")
- (license (list license:expat license:asl2.0))))
-
-(define-public rust-postgres-types-0.2
- (package
- (name "rust-postgres-types")
- (version "0.2.1")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "postgres-types" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "0brsqkydz0grfy60nc1d0hxa9jbpim0c7c52v467nrdpw4ql23s3"))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs
- (("rust-bit-vec" ,rust-bit-vec-0.6)
- ("rust-bytes" ,rust-bytes-1)
- ("rust-chrono" ,rust-chrono-0.4)
- ("rust-eui48" ,rust-eui48-0.4)
- ("rust-fallible-iterator" ,rust-fallible-iterator-0.2)
- ("rust-geo-types" ,rust-geo-types-0.7)
- ("rust-geo-types" ,rust-geo-types-0.6)
- ("rust-postgres-derive" ,rust-postgres-derive-0.4)
- ("rust-postgres-protocol" ,rust-postgres-protocol-0.6)
- ("rust-serde" ,rust-serde-1)
- ("rust-serde-json" ,rust-serde-json-1)
- ("rust-time" ,rust-time-0.2)
- ("rust-uuid" ,rust-uuid-0.8))))
- (home-page "https://github.com/sfackler/rust-postgres")
- (synopsis "Conversions between Rust and Postgres values")
- (description
- "This package provides a Rust implementation for conversions between Rust
-and Postgres values.")
- (license (list license:expat license:asl2.0))))
-
(define-public rust-powerfmt-0.2
(package
(name "rust-powerfmt")