summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-02-09 21:08:52 +0000
committerSharlatan Hellseher <[email protected]>2025-02-09 21:09:38 +0000
commit5754f6a0976fb06d9bf1702b9b98e991d7b4dbc0 (patch)
tree978525f64ce0f3d7c1ba8670a4a1c5f1782d1ed2
parent02d1d6907ee6fcda816b287bddc4dc64878523b4 (diff)
gnu: python-paste: Update to 3.10.1.
* gnu/packages/python-web.scm (python-paste): Update to 3.10.1. [source] <uri>: Adjust it as PyPI archive has been changed. <patches>: Remove them. <snippet>: Likewise, all tests passed without modifications. [propagated-inputs]: Remove python-six and python-setuptools. [native-inputs]: Add python-setuptools. * gnu/packages/patches/python-paste-remove-timing-test.patch: Delete file. * gnu/local.mk (python-paste-remove-timing-test.patch): Deregister patch. Change-Id: I8b8560318e01fdcddfeb2f6916414e1c59cbcb6a
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/python-paste-remove-timing-test.patch16
-rw-r--r--gnu/packages/python-web.scm21
3 files changed, 7 insertions, 31 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 2d4608378b..117280fc11 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -2108,7 +2108,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-memcached-syntax-warnings.patch \
%D%/packages/patches/python-mox3-python3.6-compat.patch \
%D%/packages/patches/python-packaging-test-arch.patch \
- %D%/packages/patches/python-paste-remove-timing-test.patch \
%D%/packages/patches/python-pyan3-fix-absolute-path-bug.patch \
%D%/packages/patches/python-pyan3-fix-positional-arguments.patch \
%D%/packages/patches/python-pytorch-fix-codegen.patch \
diff --git a/gnu/packages/patches/python-paste-remove-timing-test.patch b/gnu/packages/patches/python-paste-remove-timing-test.patch
deleted file mode 100644
index 6ab8d1a59c..0000000000
--- a/gnu/packages/patches/python-paste-remove-timing-test.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Remove this test to verify that things were modified since a certain time.
-
-That assumption doesn't hold up when your environment doesn't have access to a
-real clock and thinks it's living in 1970 :)
-
---- a/tests/test_fileapp.py 2015-04-23 13:48:37.000000000 -0700
-+++ b/tests/test_fileapp.py 2016-02-22 19:20:08.332802417 -0800
-@@ -223,8 +223,6 @@
- status=304)
- res = app.get('/', headers={'If-None-Match': 'asdf'},
- status=200)
-- res = app.get('/', headers={'If-Modified-Since': 'Sat, 1 Jan 2005 12:00:00 GMT'},
-- status=200)
- res = app.get('/', headers={'If-Modified-Since': last_mod + '; length=100'},
- status=304)
- res = app.get('/', headers={'If-Modified-Since': 'invalid date'},
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 4f6287c0b6..b4f6da8f02 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6541,28 +6541,21 @@ package from WTForms. The package has been renamed to
(define-public python-paste
(package
(name "python-paste")
- (version "3.5.2")
+ (version "3.10.1")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "Paste" version))
+ (uri (pypi-uri "paste" version))
(sha256
(base32
- "1xjakxrdvy4kgfy170gb9bl8zp9hqjjwh1h1vlik1pxw606399ym"))
- (patches (search-patches "python-paste-remove-timing-test.patch"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; This test calls out to the internet.
- (delete-file "tests/test_proxy.py") #t))))
+ "0jjyl39r5ncx98rwi855x71qrwvwm59idgn7q0c7m2jyb8314g8w"))))
(build-system pyproject-build-system)
(native-inputs
- (list python-pytest python-wheel))
- (propagated-inputs
- (list python-six python-setuptools))
+ (list python-pytest
+ python-setuptools
+ python-wheel))
(home-page "https://pythonpaste.readthedocs.io/")
- (synopsis
- "Python web development tools, focusing on WSGI")
+ (synopsis "Python web development tools, focusing on WSGI")
(description
"Paste provides a variety of web development tools and middleware which
can be nested together to build web applications. Paste's design closely