summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-27 21:04:28 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:30 +0000
commit5567efc1141b76bc503adffb7920c3d1b3d75454 (patch)
treec40a412f6b3a2522166e68647bd0ac3be7010d72
parenta3f747f94faaa6c23f05d81f3752835d233f0929 (diff)
gnu: go-github-com-pierrec-lz4-v4: Fix build.
* gnu/packages/golang-compression.scm (go-lz4c): Move "native-inputs" from here ... (go-github-com-pierrec-lz4-v4): ... to here. Change-Id: I9bc406b0dd8f99bff80b99fb3a9268d5e0c07a59
-rw-r--r--gnu/packages/golang-compression.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/golang-compression.scm b/gnu/packages/golang-compression.scm
index f0f253c7e3..f73b1c1195 100644
--- a/gnu/packages/golang-compression.scm
+++ b/gnu/packages/golang-compression.scm
@@ -386,7 +386,12 @@ LZ4 data blocks. The implementation is based on the reference C
(build-system go-build-system)
(arguments
(list
- #:import-path "github.com/pierrec/lz4/v4"))))
+ #:import-path "github.com/pierrec/lz4/v4"))
+ ;; For CLI.
+ (native-inputs
+ (list go-code-cloudfoundry-org-bytefmt
+ go-github-com-pierrec-cmdflag
+ go-github-com-schollz-progressbar-v3))))
(define-public go-github-com-ulikunitz-xz
(package
@@ -469,10 +474,6 @@ tool."))))
#:install-source? #f
#:import-path "github.com/pierrec/lz4/cmd/lz4c"
#:unpack-path "github.com/pierrec/lz4"))
- (native-inputs
- (list go-code-cloudfoundry-org-bytefmt
- go-github-com-pierrec-cmdflag
- go-github-com-schollz-progressbar-v3))
(description
(string-append (package-description go-github-com-pierrec-lz4-v4)
" This package provides an additional command line