summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-11-22 15:42:08 +0000
committerSharlatan Hellseher <[email protected]>2024-12-13 20:23:29 +0000
commit53f4a680faf7b0a8e9810fa199f7c1eb95e48534 (patch)
treedd76ba3fbd49c2abf694e336d5470254b5cae2d9
parent7b7b0563e2167a4af30502db1b62b3dd8a12907c (diff)
gnu: python-fastjsonschema: Update to 2.20.0.
* gnu/packages/python-xyz.scm (python-fastjsonschema): Update to 2.20.0. Adjust style. [source]: Swap to git checkout containing tests. [arguments]<tests>: Enable them. [native-inputs]: Remove python-pylint. Change-Id: Ia5f9cccc3f225c621a56a17da07e5ea43d4489f9
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 343099713e..584f407952 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17878,29 +17878,28 @@ significantly better performance.")
(define-public python-fastjsonschema
(package
(name "python-fastjsonschema")
- (version "2.15.1")
+ (version "2.20.0")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "fastjsonschema" version))
+ (method git-fetch) ; no tests in PyPI release
+ (uri (git-reference
+ (url "https://github.com/horejsek/python-fastjsonschema")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1ln2j60jzyn6p8i8ljygfgrji58hc23452g7nllkcjdk4p93c7v7"))))
+ (base32 "0aqj7hf1fgana9hh9la475wiyivcr46fra1bvigp00805g14k599"))))
(build-system pyproject-build-system)
- (arguments `(#:tests? #f)) ;no tests included
(native-inputs
(list python-colorama
python-json-spec
python-jsonschema
- python-pylint
python-pytest
python-pytest-benchmark
python-pytest-cache
python-setuptools
python-wheel))
- (home-page
- "https://github.com/horejsek/python-fastjsonschema")
- (synopsis
- "Fast Python implementation of JSON schema")
+ (home-page "https://github.com/horejsek/python-fastjsonschema")
+ (synopsis "Fast Python implementation of JSON schema")
(description
"This library implements validation of JSON documents by JSON schema for
drafts 04, 06 and 07.")