summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <[email protected]>2024-05-10 00:54:02 +0200
committerSharlatan Hellseher <[email protected]>2024-12-13 20:18:55 +0000
commit4f1e509142d0f488011deafd73c6b52aae312aa7 (patch)
tree4f71ca25cb8d05c3b244a276034965451be7a50a
parent6a37ea12b7203b9d186d844357e5a892603cb732 (diff)
gnu: python-flake8-isort: Move to pyproject-build-system.
* gnu/packages/python-xyz.scm (python-flake8-isort): [build-system]: Move to pyproject-build-system. [arguments]: Remove uneeded field. Change-Id: Ie8c32f6164030daf28760a58f33aff1d540fc6a5 Signed-off-by: Nicolas Goaziou <[email protected]>
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 1 insertions, 9 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d441a81108..e8660c79cd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15377,15 +15377,7 @@ TODO notes checker plugin for flake8.")
(uri (pypi-uri "flake8-isort" version))
(sha256
(base32 "0gk4q504v42hdzpkndczc0kkwnr85jn1h5pvb561jh65p91r6qyl"))))
- (build-system python-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv" "run_tests.py")))))))
+ (build-system pyproject-build-system)
(propagated-inputs (list python-flake8 python-isort))
(native-inputs (list python-pytest))
(home-page "https://github.com/gforcada/flake8-isort")