summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-06 21:26:50 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:40 +0000
commit48637ed9f55ebbb16e7205b4ef02cd8fa9b3bd0a (patch)
tree7708773c83647ab00f419c78b396c303ec49bc3f
parent598c55929f2fe3cd061812c22b98b96df32dd01b (diff)
gnu: Add go-github-com-dgryski-go-rendezvous.
* gnu/packages/golang-crypto.scm (go-github-com-dgryski-go-rendezvous): New variable. Change-Id: I863e2044ab365a80763226f8b8e8ea88719fe073
-rw-r--r--gnu/packages/golang-crypto.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index dba918108f..c36d2c0117 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -790,6 +790,30 @@ MetroHash}, a high quality, high performance hash algorithm.")
"This package implements a hash/displace minimal perfect hash function.")
(license license:expat)))
+(define-public go-github-com-dgryski-go-rendezvous
+ (package
+ (name "go-github-com-dgryski-go-rendezvous")
+ (version "0.0.0-20200823014737-9f7001d12a5f")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dgryski/go-rendezvous")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0hhdbsm5k19kh1fyxs4aibza9jylils4p3555lr8xalhj2iz3zlz"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/dgryski/go-rendezvous"))
+ (home-page "https://github.com/dgryski/go-rendezvous")
+ (synopsis "Hashing functions for Golang")
+ ;; Project provides no README.
+ (description
+ "This package provides a hashing function.")
+ (license license:expat)))
+
(define-public go-github-com-dvsekhvalnov-jose2go
(package
(name "go-github-com-dvsekhvalnov-jose2go")