summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-20 21:44:40 +0000
committerSharlatan Hellseher <[email protected]>2024-12-30 15:07:41 +0000
commit3fc77b6987eaea145cc5a3453f56ae6c53b44758 (patch)
tree75b7bf6dbeba636d191398a34606b50a0ac629c0
parent61884eb3b6287c5b1fd8c8ca7c198a97bf09c0e7 (diff)
gnu: python-stsci-stimage: Adjust inputs.
* gnu/packages/astronomy.scm (python-stsci-stimage): [native-inputs]: Add python-setuptools. Sort alphabetically. Change-Id: I75fe8eb911b13a83bbe096aec665a33fde05cfdf
-rw-r--r--gnu/packages/astronomy.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 3805ee5cee..a4a315e92a 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -5201,8 +5201,6 @@ task}.")
(define-public python-stsci-stimage
(package
(name "python-stsci-stimage")
- ;; PyPI version was 0.2.8 but the latest version tag on GiHub was 0.2.7,
- ;; see <https://github.com/spacetelescope/stsci.stimage/issues/38>
(version "0.2.9")
(source (origin
(method url-fetch)
@@ -5225,13 +5223,14 @@ task}.")
#$(this-package-native-input "python-waf") "/bin/waf")
"waf")
(invoke "python" "waf" "configure" "build"))))))
- (propagated-inputs
- (list python-numpy))
(native-inputs
(list python-pytest
- python-wheel
+ python-setuptools
python-setuptools-scm
- python-waf))
+ python-waf
+ python-wheel))
+ (propagated-inputs
+ (list python-numpy))
(home-page "https://stscistimage.readthedocs.io/en/latest/")
(synopsis "STScI image processing")
(description