summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <[email protected]>2024-12-24 01:13:01 +0800
committerZheng Junjie <[email protected]>2025-01-25 01:05:26 +0800
commit3228924c7bdebbaf6eed176d29c4b96a26dad2ef (patch)
tree87827324a8d2f5e3d83a4e883bff1f28f3a630f7
parente404f8ef4c5afa6d9be28642a8028f3ff59189f0 (diff)
gnu: gdbm: Fix build to loongarch64.
* gnu/packages/dbm.scm (gdbm)[arguments]: When target is loongarch64, Add update-config phase. [native-inputs]: When target is loongarch64, Add config. Change-Id: I1fd1b0b4171ae3cddbcc1683f8cb12ed85fa5da8
-rw-r--r--gnu/packages/dbm.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/dbm.scm b/gnu/packages/dbm.scm
index 7c36d30a34..433d469ae8 100644
--- a/gnu/packages/dbm.scm
+++ b/gnu/packages/dbm.scm
@@ -189,7 +189,22 @@ SQL, Key/Value, XML/XQuery or Java Object storage for their data model.")
(base32
"1kfapds42j1sjq6wl7fygipw5904wpbfa5kwppj3mwgz44fhicbl"))))
(arguments `(#:configure-flags '("--enable-libgdbm-compat"
- "--disable-static")))
+ "--disable-static")
+ ,@(if (target-loongarch64?)
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'update-config
+ (lambda* (#:key native-inputs inputs #:allow-other-keys)
+ (for-each (lambda (file)
+ (install-file
+ (search-input-file
+ (or native-inputs inputs)
+ (string-append "/bin/" file)) "build-aux"))
+ '("config.guess" "config.sub"))))))
+ '())))
+ (native-inputs (if (target-loongarch64?)
+ (list config)
+ '()))
(build-system gnu-build-system)
(home-page "https://www.gnu.org.ua/software/gdbm")
(synopsis