summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-20 00:28:15 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:42:11 +0000
commit2cf9fb3bf72721cb9ca1c553d725c761b4e2748e (patch)
tree19b01252cccfd7a71702355ae0e3b84484fe1fb7
parentdd4ee37f9af03d4dc4836d92d2ff096c8d10f299 (diff)
gnu: go-golang-org-x-vuln: Simplify.
* gnu/packages/golang-build.scm (go-golang-org-x-vuln): [arguments] <skip-build?>: Set to #t, as no go files in project's root. <test-flags>: Skip 3 tests. <test-subdirs>: Select them here. <phases>: Use default 'check. Change-Id: I7e6860f63c559813055cc5383b6f608855a9490d
-rw-r--r--gnu/packages/golang-build.scm19
1 files changed, 7 insertions, 12 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index 36bda3d48c..b20437fa8d 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -1090,19 +1090,14 @@ Go programming language.")
(build-system go-build-system)
(arguments
(list
+ #:skip-build? #t
#:import-path "golang.org/x/vuln"
- #:phases
- #~(modify-phases %standard-phases
- ;; XXX: Workaround for go-build-system's lack of Go modules support.
- (delete 'build)
- (replace 'check
- (lambda* (#:key tests? import-path #:allow-other-keys)
- (when tests?
- (with-directory-excursion (string-append "src/" import-path)
- (invoke "go" "test" "-v"
- "./doc/..."
- "./internal/..."
- "./scan/..."))))))))
+ ;; ts.RunParallel undefined (type *cmdtest.TestSuite has no field or
+ ;; method RunParallel)
+ ;;
+ ;; go: modules disabled by GO111MODULE=off
+ #:test-flags #~(list "-skip" "TestVet|TestGoModTidy|Test58509")
+ #:test-subdirs #~(list "internal/..." "scan/..." ".")))
(propagated-inputs
(list go-github-com-google-go-cmdtest
go-github-com-google-go-cmp