summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-07 12:37:00 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:41 +0000
commit2ad343014b45906a1cf069ca847727d0414da016 (patch)
tree4a03949cdb09581efc0d3b0d5ed783953e042054
parent3d098128bdc9e38705ab3d27eac2d49f77626cf1 (diff)
gnu: go-github-com-apparentlymart-go-textseg-v13: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-apparentlymart-go-textseg-v13, go-github-com-apparentlymart-go-textseg-autoversion): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Ifc8d6bf20573632f70bdce555736e83273b62f1f
-rw-r--r--gnu/packages/golang-xyz.scm37
-rw-r--r--gnu/packages/golang.scm37
2 files changed, 37 insertions, 37 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 204aafb4bb..6aeb4c690e 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -989,6 +989,43 @@ commands.")
"This package implements optimal parameters for data-types.")
(license license:expat)))
+(define-public go-github-com-apparentlymart-go-textseg-v13
+ (package
+ (name "go-github-com-apparentlymart-go-textseg-v13")
+ (version "13.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/apparentlymart/go-textseg")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0gdgi0d52rq1xsdn9icc8lghn0f2q927cifmrlfxflf7bf21vism"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:unpack-path "github.com/apparentlymart/go-textseg/v13"
+ #:import-path "github.com/apparentlymart/go-textseg/v13/textseg"))
+ (native-inputs
+ (list ruby))
+ (home-page "https://github.com/apparentlymart/go-textseg")
+ (synopsis "Go implementation of Unicode Text Segmentation")
+ (description
+ "This package provides an implementation of the Unicode Text Segmentation
+specification for Go. Specifically, it currently includes only the grapheme
+cluster segmentation algorithm.")
+ ;; Project is released under Expat terms. Some parts use Unicode and
+ ;; ASL2.0 licenses.
+ (license (list license:expat license:unicode license:asl2.0))))
+
+(define-public go-github-com-apparentlymart-go-textseg-autoversion
+ (package
+ (inherit go-github-com-apparentlymart-go-textseg-v13)
+ (name "go-github-com-apparentlymart-go-textseg-autoversion")
+ (arguments
+ '(#:unpack-path "github.com/apparentlymart/go-textseg/autoversion"
+ #:import-path "github.com/apparentlymart/go-textseg/autoversion/textseg"))))
+
(define-public go-github-com-arbovm-levenshtein
(package
(name "go-github-com-arbovm-levenshtein")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 47d8699286..e883911490 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1100,43 +1100,6 @@ network traffic so that it is not identified and subsequently blocked by network
filtering devices.")
(license license:bsd-2))))
-(define-public go-github-com-apparentlymart-go-textseg-v13
- (package
- (name "go-github-com-apparentlymart-go-textseg-v13")
- (version "13.0.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/apparentlymart/go-textseg")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0gdgi0d52rq1xsdn9icc8lghn0f2q927cifmrlfxflf7bf21vism"))))
- (build-system go-build-system)
- (arguments
- '(#:unpack-path "github.com/apparentlymart/go-textseg/v13"
- #:import-path "github.com/apparentlymart/go-textseg/v13/textseg"))
- (native-inputs
- (list ruby))
- (home-page "https://github.com/apparentlymart/go-textseg")
- (synopsis "Go implementation of Unicode Text Segmentation")
- (description
- "This package provides an implementation of the Unicode Text Segmentation
-specification for Go. Specifically, it currently includes only the grapheme
-cluster segmentation algorithm.")
- ;; Project is released under Expat terms. Some parts use Unicode and
- ;; ASL2.0 licenses.
- (license (list license:expat license:unicode license:asl2.0))))
-
-(define-public go-github-com-apparentlymart-go-textseg-autoversion
- (package
- (inherit go-github-com-apparentlymart-go-textseg-v13)
- (name "go-github-com-apparentlymart-go-textseg-autoversion")
- (arguments
- '(#:unpack-path "github.com/apparentlymart/go-textseg/autoversion"
- #:import-path "github.com/apparentlymart/go-textseg/autoversion/textseg"))))
-
(define-public go-github-com-operatorfoundation-shapeshifter-transports
(package
(name "go-github-com-operatorfoundation-shapeshifter-transports")