summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2025-01-09 12:11:51 +0000
committerSharlatan Hellseher <[email protected]>2025-01-21 23:47:48 +0000
commit297f3f279a54c9337ccd55dc04d4ba6574ef4f77 (patch)
tree9f24e6a57db0e2736ad400d7b7373f5104b9ef71
parent519d7cf948736887e1c6a46257b275c78091a57c (diff)
gnu: Add go-github-com-twpayne-go-pinentry.
* gnu/packages/golang-crypto.scm (go-github-com-twpayne-go-pinentry, go-github-com-twpayne-go-pinentry-v4): New variables. Change-Id: Iec28d1a0c9215d9d31212ceaa4ccb4046bf0fab3
-rw-r--r--gnu/packages/golang-crypto.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 7e3588f209..4c88150ad3 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -1958,6 +1958,52 @@ revision (aka MurmurHash3). Reference algorithm has been slightly hacked as to
support the streaming mode required by Go's standard Hash interface.")
(license license:bsd-3)))
+(define-public go-github-com-twpayne-go-pinentry
+ (package
+ (name "go-github-com-twpayne-go-pinentry")
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/twpayne/go-pinentry")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ixvvfd7ywsgj0jk1plb4h2g5bpmw86qc89m02c184jh5ndawhip"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/twpayne/go-pinentry"))
+ (native-inputs
+ (list go-github-com-alecthomas-assert-v2
+ go-github-com-golang-mock))
+ (propagated-inputs
+ (list go-github-com-rs-zerolog))
+ (home-page "https://github.com/twpayne/go-pinentry")
+ (synopsis "Golang client to GnuPG's pinentry")
+ (description
+ "Package pinentry provides a client to @code{GnuPG's} pinentry.")
+ (license license:expat)))
+
+(define-public go-github-com-twpayne-go-pinentry-v4
+ (package
+ (inherit go-github-com-twpayne-go-pinentry)
+ (name "go-github-com-twpayne-go-pinentry-v4")
+ (version "4.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/twpayne/go-pinentry")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1z9h2lg5xd3g6dd9avcfx0nnwdybr2yibmsw7akl6pz0cls3sf63"))))
+ (arguments
+ (list
+ #:import-path "github.com/twpayne/go-pinentry/v4"))))
+
(define-public go-github-com-xanzy-ssh-agent
(package
(name "go-github-com-xanzy-ssh-agent")