summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-11-22 13:19:40 +0000
committerSharlatan Hellseher <[email protected]>2024-12-13 20:23:28 +0000
commit27fdf6fa94872a4fec99809cacb6afbc1a7077ec (patch)
treedf795c1aaf9d10a5f036f4cc5b3269c0db21761c
parent1305fc004a7d150f3dc6647343d9d8f0d3bc4652 (diff)
gnu: python-prettytable: Update to 3.12.0.
* gnu/packages/python-xyz.scm (python-prettytable): Update to 3.12.0. [build-system]: Swap to pyproejct-build-system. [arguments]<phases>: Use custom 'check phase. [native-inputs]: Remove python-pytest-lazy-fixture; add python-hatchling, python-hatch-vcs, python-pytest-cov, and python-pytest-lazy-fixtures. Change-Id: I19d93bb92dec4f65d581dd8fcecbc137e1fdd4d6
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 10 insertions, 14 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1cb37eeb62..343099713e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16525,27 +16525,23 @@ functional languages.")
(define-public python-prettytable
(package
(name "python-prettytable")
- (version "3.3.0")
+ (version "3.12.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "prettytable" version))
(sha256
- (base32
- "1c599w31i2ndzbkn85xwsgv9sd2j16r56dl922w4jh3rs97vb3hi"))))
- (build-system python-build-system)
- (arguments
- (list #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv")))))))
+ (base32 "0168xqdr0i9r4p3a3hjd4n7f133lp4xkxhvfx63aqisplcdkwjzh"))))
+ (build-system pyproject-build-system)
(native-inputs
- (list python-pytest
- python-pytest-lazy-fixture
+ (list python-hatchling
+ python-hatch-vcs
+ python-pytest
+ python-pytest-cov
+ python-pytest-lazy-fixtures
python-setuptools-scm))
- (propagated-inputs (list python-wcwidth))
+ (propagated-inputs
+ (list python-wcwidth))
(home-page "https://github.com/jazzband/prettytable")
(synopsis "Display tabular data in an ASCII table format")
(description