summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <[email protected]>2025-01-06 14:00:32 +0100
committerLudovic Courtès <[email protected]>2025-01-20 00:14:13 +0100
commit2546f50651a5e784e960daa63cfca287de0a6865 (patch)
tree5dd479710b7f7410da6b63e692b739782f400838
parentf00dedf06aca70e295ffb20a2398d9839185fc68 (diff)
gnu: Add emacs-magit-stgit.
* gnu/packages/emacs-xyz.scm (emacs-magit-stgit): New variable. Signed-off-by: Ludovic Courtès <[email protected]>
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0d808a2bff..88678ada1d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1882,6 +1882,34 @@ changes. There is support for cherry picking, reverting, merging,
rebasing, and other common Git operations.")
(license license:gpl3+)))
+(define-public emacs-magit-stgit
+ (let ((commit "51168b7438dfb5ca6b9239b8564397cc0cc6e798")
+ (revision "0"))
+ (package
+ (name "emacs-magit-stgit")
+ (version (git-version "2.2.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/stacked-git/magit-stgit.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1z2dhc1m510iyrks5lxp3jlqg4n7qwwirbmxg4c4ll0xngfhnalc"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-magit emacs-transient))
+ (home-page "https://github.com/stacked-git/magit-stgit")
+ (synopsis "StGit extension for Magit")
+ (description
+ "This package provides basic support for @code{stgit} in
+@code{emacs-magit}. When @code{magit-stgit-mode} is turned on, the
+current patch series is displayed in the status buffer. While point is on a
+patch the changes it introduces can be shown using @code{RET}, it can be selected
+as the current patch using @code{a}, and it can be discarded using @code{k}. Other
+@code{StGit} commands are available from the @code{StGit} transient on @code{/}.")
+ (license license:gpl3+))))
+
(define-public emacs-magit-svn
(package
(name "emacs-magit-svn")