summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <[email protected]>2024-12-10 15:17:43 +0000
committerSharlatan Hellseher <[email protected]>2024-12-30 15:07:39 +0000
commit24a8b7350545a1f02bdc98fb67c8219b8afcd786 (patch)
tree7db9d3cdb5d7a3a6813ac6d555522813e1ad1153
parent6a5a1f9564f7f62b4048c312715f7025c612d771 (diff)
gnu: python-astropy: Update to 6.1.7.
* gnu/packages/astronomy.scm (python-astropy): Update to 6.1.7. Change-Id: I10eb5927df83392552535f00dcfb649e43d9129c
-rw-r--r--gnu/packages/astronomy.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 09540c071c..0a466db8f6 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3262,16 +3262,20 @@ stack typically requires post-processing, including sharpening (e.g. via
deconvolution). Such post-processing is not performed by Stackistry.")
(license license:gpl3+)))
+;; XXX: Upgrading to the latest version requires Python3.11+ and fresh
+;; versions of numpy, PyYAML, packaging, Pandas and matplotlib, see
+;; <https://github.com/astropy/astropy/blob/v7.0.0/CHANGES.rst
+;; #other-changes-and-additions>.
(define-public python-astropy
(package
(name "python-astropy")
- (version "6.1.6")
+ (version "6.1.7")
(source
(origin
(method url-fetch)
(uri (pypi-uri "astropy" version))
(sha256
- (base32 "0iv8mkdflfprigv3g6666v80nvg6blwz0989hqw232g7gms57qb3"))
+ (base32 "1vspagb4vbmkl6fm3mr78577dgdq992ggwkd5qawpdh6cccaq1d4"))
(modules '((guix build utils)))
(snippet
'(begin