summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-12-27 15:04:06 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:56:58 +0200
commit1f26de02f0c2122ef6622422facaef0787961c69 (patch)
tree0df866b3b89273f748954a6149f1798e92681851
parentf5128a6f50f50769945ea4e78931945533458a5a (diff)
gnu: rust-dunce-1: Move to (gnu packages crates-windows).
* gnu/packages/crates-io.scm (rust-dunce-1): Move from here ... * gnu/packages/crates-windows.scm: ... to here. Change-Id: I230d2476df38f735cb20a4b375befa6e9ae94509
-rw-r--r--gnu/packages/crates-io.scm22
-rw-r--r--gnu/packages/crates-windows.scm22
-rw-r--r--gnu/packages/shells.scm1
3 files changed, 23 insertions, 22 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 583daedc94..d796d0edf8 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -21769,28 +21769,6 @@ Rust.")
"A library for running child processes.")
(license license:expat)))
-(define-public rust-dunce-1
- (package
- (name "rust-dunce")
- (version "1.0.4")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "dunce" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "0fqcbwfclldbknmawi69l6zyncaiqzxkpbybcb2cc7jmlxnqrkjn"))))
- (build-system cargo-build-system)
- (home-page "https://gitlab.com/kornelski/dunce")
- (synopsis "Normalize Windows paths to the most compatible format")
- (description
- "This crate converts Windows UNC paths to the MS-DOS-compatible format
-whenever possible, but leaves UNC paths as-is when they can't be unambiguously
-expressed in a simpler way. This allows legacy programs to access all paths
-they can possibly access, and doesn't break any paths for UNC-aware
-programs.")
- (license (list license:cc0 license:expat-0 license:asl2.0))))
-
(define-public rust-dyn-clone-1
(package
(name "rust-dyn-clone")
diff --git a/gnu/packages/crates-windows.scm b/gnu/packages/crates-windows.scm
index 38e2d93a8a..0de0031aaf 100644
--- a/gnu/packages/crates-windows.scm
+++ b/gnu/packages/crates-windows.scm
@@ -185,6 +185,28 @@ Windows Credential Manager.")
"This package provides a library which provides an interface for @code{ConPTY}.")
(license license:expat)))
+(define-public rust-dunce-1
+ (package
+ (name "rust-dunce")
+ (version "1.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "dunce" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0fqcbwfclldbknmawi69l6zyncaiqzxkpbybcb2cc7jmlxnqrkjn"))))
+ (build-system cargo-build-system)
+ (home-page "https://gitlab.com/kornelski/dunce")
+ (synopsis "Normalize Windows paths to the most compatible format")
+ (description
+ "This crate converts Windows UNC paths to the MS-DOS-compatible format
+whenever possible, but leaves UNC paths as-is when they can't be unambiguously
+expressed in a simpler way. This allows legacy programs to access all paths
+they can possibly access, and doesn't break any paths for UNC-aware
+programs.")
+ (license (list license:cc0 license:expat-0 license:asl2.0))))
+
(define-public rust-windows-0.48
(package
(name "rust-windows")
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index be8fa8d7a7..cfbc4cd97e 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -48,6 +48,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages crates-graphics)
#:use-module (gnu packages crates-io)
+ #:use-module (gnu packages crates-windows)
#:use-module (gnu packages curl)
#:use-module (gnu packages documentation)
#:use-module (gnu packages groff)