summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <[email protected]>2024-07-19 11:18:02 +0200
committerLiliana Marie Prikler <[email protected]>2025-03-02 20:31:29 +0100
commit1b86cdc0e1d39d888e3da32e3c494a9ac3b40ba3 (patch)
treefd61efc51082bdfd1078fbc7351a5a558ff0e67a
parentf008d763950fbedef1d479621214425f6f21df55 (diff)
gnu: gnome-chess: Update to 46.0.
* gnu/packages/games.scm (gnome-chess): Update to 46.0. [arguments]: Adjust accordingly. [inputs]: Replace gtk+ with gtk. Add libadwaita.
-rw-r--r--gnu/packages/games.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e8fd7ac9b3..89675e91e6 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2292,7 +2292,7 @@ in one tile.")
(define-public gnome-chess
(package
(name "gnome-chess")
- (version "3.37.3")
+ (version "46.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/gnome-chess/"
@@ -2300,7 +2300,7 @@ in one tile.")
"gnome-chess-" version ".tar.xz"))
(sha256
(base32
- "09axf0q1mp13sv8cs0syfg8ahcd9r2qb26278r09j6s4njxmkfv4"))))
+ "1rzx8qxrfsicdmkyka434nv7adrh4x4qn6dri5bjqcallzh91g52"))))
(build-system meson-build-system)
(arguments
'(#:glib-or-gtk? #t
@@ -2309,11 +2309,13 @@ in one tile.")
(add-after 'unpack 'skip-gtk-update-icon-cache
;; Don't create 'icon-theme.cache'.
(lambda _
- (substitute* "meson_post_install.py"
- (("gtk-update-icon-cache") "true"))
- #t)))))
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false")
+ (("update_desktop_database: true")
+ "update_desktop_database: false")))))))
(inputs
- (list gtk+ librsvg))
+ (list gtk libadwaita librsvg))
(native-inputs
`(("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin") ; for desktop-file-validate and appstream-util