summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <[email protected]>2025-01-17 15:05:00 +0800
committerjgart <[email protected]>2025-01-19 21:40:18 -0600
commit16eda2a3ade0b9693ad8acc8327b471722bd1c73 (patch)
treefc011726de2dc0dacec7131f09df58498c28169e
parentb1e7688e19542a14fe5c0140c2dd1621f0e868b7 (diff)
gnu: solfege: Build and install manual.
* gnu/packages/music.scm (solfege)[arguments]: Add 'build-manual phase. Pass "--enable-docbook-stylesheet" to configure-flags. [native-inputs]: Add docbook-xsl, docbook-xml-4.1.2, itstool and libxslt. Change-Id: Icef6c393e1d4c6413e53ef9de9ffc16d5e973a94 Signed-off-by: jgart <[email protected]>
-rw-r--r--gnu/packages/music.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index f3fbe76fff..eeee00871d 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2206,6 +2206,13 @@ Key features include:
(list
#:tests? #f ;xmllint attempts to download DTD
#:test-target "test"
+ #:configure-flags
+ #~(list (string-append "--enable-docbook-stylesheet="
+ #$(this-package-native-input "docbook-xsl")
+ "/xml/xsl/"
+ #$(package-name docbook-xsl) "-"
+ #$(package-version docbook-xsl)
+ "/html/chunk.xsl"))
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'set-version
@@ -2250,6 +2257,9 @@ for path in [path for path in sys.path if 'site-packages' in path]: site.addsite
(substitute* "run-solfege.py"
(("prefix = os.path.*$")
(string-append "prefix = " #$output)))))
+ (add-after 'build 'build-manual
+ (lambda _
+ (invoke "make" "update-manual")))
(add-after 'install 'wrap-program
(lambda* (#:key outputs #:allow-other-keys)
;; Make sure 'solfege' runs with the correct PYTHONPATH.
@@ -2274,6 +2284,10 @@ for path in [path for path in sys.path if 'site-packages' in path]: site.addsite
pkg-config
txt2man
libxml2 ; for tests
+ docbook-xsl ; for manual
+ docbook-xml-4.1.2
+ itstool
+ libxslt
ghostscript
texinfo))
(home-page "https://www.gnu.org/software/solfege/")