summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <[email protected]>2025-03-03 14:19:59 +0200
committerEfraim Flashner <[email protected]>2025-03-03 14:19:59 +0200
commit162179e787f4d196e809dd19c74b7ad8318d7ac1 (patch)
tree2198376946020fcd3a465bac37a58fc1e7923c61
parent25d99dd80a913d34cd447d57b90dabf12808af00 (diff)
gnu: python-pandas: Skip some tests on 32bit systems.
* gnu/packages/python-science.scm (python-pandas)[arguments]: Adjust the test-flags when not building on a 64bit system to skip some incompatible tests. Change-Id: Ic581cc6bf4ade2d92425c38df10bc45beaf4009e
-rw-r--r--gnu/packages/python-science.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 679074c760..7f352ca616 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2015 Federico Beffa <[email protected]>
;;; Copyright © 2016 Ben Woodcroft <[email protected]>
;;; Copyright © 2016 Hartmut Goebel <[email protected]>
-;;; Copyright © 2016, 2022-2024 Efraim Flashner <[email protected]>
+;;; Copyright © 2016, 2022-2025 Efraim Flashner <[email protected]>
;;; Copyright © 2016-2020, 2022 Marius Bakke <[email protected]>
;;; Copyright © 2019 Tobias Geerinckx-Rice <[email protected]>
;;; Copyright © 2019, 2021, 2022, 2023, 2024 Maxim Cournoyer <[email protected]>
@@ -1467,7 +1467,14 @@ doing practical, real world data analysis in Python.")
"test_savefig"
;; It requires a fresh python-tzdata, including new
;; timezones.
- "test_repr")
+ "test_repr"
+ ;; These tests should be skipped on 32bit systems:
+ ;; Cannot cast array data from dtype('int64') to dtype('int32')
+ #$@(if (not (target-64bit?))
+ #~("test_inf_bound_infinite_recursion"
+ "test_reindex_behavior_with_interval_index"
+ "test_repeating_interval_index_with_infs")
+ #~()))
" and not "))
#:phases
#~(modify-phases %standard-phases